diff mbox series

[bug#64905,v4,11/11] gnu: tree-sitter: Re-indent.

Message ID 507ddb533782784555f99155c0047cb5066f22d5.1692539095.git.hako@ultrarare.space
State New
Headers show
Series Update tree-sitter{, -{bash, c{, pp, -sharp}, go, java, {java, type}script, python, rust}}, | expand

Commit Message

Hilton Chain Aug. 20, 2023, 2:01 p.m. UTC
* gnu/packages/tree-sitter.scm (tree-sitter,tree-sitter-javascript)
(tree-sitter-cpp,tree-sitter-go,tree-sitter-python): Re-indent.
---
 gnu/packages/tree-sitter.scm | 98 ++++++++++++++++++------------------
 1 file changed, 49 insertions(+), 49 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index bb845b104d..44ba11f1a9 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -96,36 +96,36 @@  (define-public python-tree-sitter
 (define-public tree-sitter
   ;; Untagged
   (let ((commit "0e4ff0bb27edf37b76fc7d35aa768b02cf4392ad"))
-  (package
-    (name "tree-sitter")
-    (version "0.20.10")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/tree-sitter/tree-sitter")
-                    (commit commit)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1bai4gdhf8w5p1i9np2kl2ms0jq6rgq98qpiipipzayb9jjjlxcy"))
-              (modules '((guix build utils)))
-              (snippet #~(begin
-                           ;; Remove bundled ICU parts
-                           (delete-file-recursively "lib/src/unicode")))))
-    (build-system gnu-build-system)
-    (inputs (list icu4c))
-    (arguments
-     (list #:phases
-           #~(modify-phases %standard-phases
-               (delete 'configure))
-           #:tests? #f ; there are no tests for the runtime library
-           #:make-flags
-           #~(list (string-append "PREFIX=" #$output)
-                   (string-append "CC=" #$(cc-for-target)))))
-    (home-page "https://tree-sitter.github.io/tree-sitter/")
-    (synopsis "Incremental parsing system for programming tools")
-    (description
-     "Tree-sitter is a parser generator tool and an incremental parsing
+    (package
+      (name "tree-sitter")
+      (version "0.20.10")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/tree-sitter/tree-sitter")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1bai4gdhf8w5p1i9np2kl2ms0jq6rgq98qpiipipzayb9jjjlxcy"))
+                (modules '((guix build utils)))
+                (snippet #~(begin
+                             ;; Remove bundled ICU parts
+                             (delete-file-recursively "lib/src/unicode")))))
+      (build-system gnu-build-system)
+      (inputs (list icu4c))
+      (arguments
+       (list #:phases
+             #~(modify-phases %standard-phases
+                 (delete 'configure))
+             #:tests? #f ; there are no tests for the runtime library
+             #:make-flags
+             #~(list (string-append "PREFIX=" #$output)
+                     (string-append "CC=" #$(cc-for-target)))))
+      (home-page "https://tree-sitter.github.io/tree-sitter/")
+      (synopsis "Incremental parsing system for programming tools")
+      (description
+       "Tree-sitter is a parser generator tool and an incremental parsing
 library.  It can build a concrete syntax tree for a source file and
 efficiently update the syntax tree as the source file is edited.
 
@@ -140,7 +140,7 @@  (define-public tree-sitter
 @end itemize
 
 This package includes the @code{libtree-sitter} runtime library.")
-    (license license:expat))))
+      (license license:expat))))
 
 (define-public tree-sitter-cli
   (package
@@ -317,11 +317,11 @@  (define-public tree-sitter-javascript
   ;; Required by tree-sitter-typescript.
   (let ((commit "7a29d06274b7cf87d643212a433d970b73969016")
         (revision "14"))
-  (tree-sitter-grammar
-   "javascript" "JavaScript(JSX)"
-   "1pk6d9g6a7bzhxmwnvfiycarcgz76wq2rgfqr0xjh7y7swfw5hvw"
-   (git-version "0.20.0" revision commit)
-   #:commit commit)))
+    (tree-sitter-grammar
+     "javascript" "JavaScript(JSX)"
+     "1pk6d9g6a7bzhxmwnvfiycarcgz76wq2rgfqr0xjh7y7swfw5hvw"
+     (git-version "0.20.0" revision commit)
+     #:commit commit)))
 
 (define-public tree-sitter-typescript
   (tree-sitter-grammar
@@ -355,11 +355,11 @@  (define-public tree-sitter-c
    "0.20.6"))
 
 (define-public tree-sitter-cpp
-      (tree-sitter-grammar
-       "cpp" "C++"
-       "0fsb6la0da3azh7m9p1w3w079bpg6074dy8jisjw1yq1w1r9grxy"
-       "0.20.3"
-       #:inputs (list tree-sitter-c)))
+  (tree-sitter-grammar
+   "cpp" "C++"
+   "0fsb6la0da3azh7m9p1w3w079bpg6074dy8jisjw1yq1w1r9grxy"
+   "0.20.3"
+   #:inputs (list tree-sitter-c)))
 
 (define-public tree-sitter-elixir
   ;; No tags at all, version in the source code is 0.19.0
@@ -409,10 +409,10 @@  (define-public tree-sitter-gomod
    #:repository-url "https://github.com/camdencheek/tree-sitter-go-mod.git"))
 
 (define-public tree-sitter-go
-    (tree-sitter-grammar
-     "go" "Go"
-     "0wlhwcdlaj74japyn8wjza0fbwckqwbqv8iyyqdk0a5jf047rdqv"
-     "0.20.0"))
+  (tree-sitter-grammar
+   "go" "Go"
+   "0wlhwcdlaj74japyn8wjza0fbwckqwbqv8iyyqdk0a5jf047rdqv"
+   "0.20.0"))
 
 (define-public tree-sitter-haskell
   ;; There are a lot of additions, the last tag was placed more than 4 years ago
@@ -463,10 +463,10 @@  (define-public tree-sitter-php
      #:commit commit)))
 
 (define-public tree-sitter-python
-    (tree-sitter-grammar
-     "python" "Python"
-     "1sxz3npk3mq86abcnghfjs38nzahx7nrn3wdh8f8940hy71d0pvi"
-     "0.20.4"))
+  (tree-sitter-grammar
+   "python" "Python"
+   "1sxz3npk3mq86abcnghfjs38nzahx7nrn3wdh8f8940hy71d0pvi"
+   "0.20.4"))
 
 (define-public tree-sitter-r
   ;; No tags