diff mbox series

[bug#70955,6/6] gnu: Add go-github-com-pion-stun-v2.

Message ID f018b66ff1f5397b1aabae1b4df652df021f9c24.1715753200.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-pion-stun-v2 and go-github-com-pion-mdns. | expand

Commit Message

Artyom V. Poptsov May 15, 2024, 6:17 a.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-pion-stun-v2): New variable.

Change-Id: I5d83caa918203c651909af667e004ab6df06498a
---
 gnu/packages/golang-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b91a28c436..5f4c7c5b95 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3114,6 +3114,41 @@  (define-public go-github-com-pion-dtls-v2
 implementation in the Go programming language.")
     (license license:expat)))
 
+(define-public go-github-com-pion-stun-v2
+  (package
+    (name "go-github-com-pion-stun")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pion/stun/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zli55ls5izpr6cw0wj0gy44872xn9rk20i8ay9cfk7j2rb60y60"))))
+    (build-system go-build-system)
+    (native-inputs (list go-github-com-stretchr-testify))
+    (propagated-inputs (list go-github-com-pion-dtls-v2
+                             go-github-com-pion-logging
+                             go-github-com-pion-transport-v3
+                             go-golang-org-x-crypto
+                             go-golang-org-x-net))
+    (arguments
+     (list
+      #:go go-1.21
+      #:import-path "github.com/pion/stun/v2"))
+    (home-page "https://github.com/pion/stun/")
+    (synopsis "Go implementation of STUN")
+    (description
+     "Package @code{stun} implements Session Traversal Utilities for
+NAT (STUN) (@url{https://tools.ietf.org/html/rfc5389, RFC 5389}) protocol and
+@url{https://pkg.go.dev/github.com/pion/stun#Client, client} with no external
+dependencies and zero allocations in hot paths.  Client
+@url{https://pkg.go.dev/github.com/pion/stun#WithRTO, supports} automatic
+request retransmissions.")
+    (license license:expat)))
+
 (define-public go-github-com-prometheus-client-model
   (package
     (name "go-github-com-prometheus-client-model")