diff mbox series

[bug#70955,4/6] gnu: Add go-github-com-pion-mdns.

Message ID a1c33ddb31fe9f3bb96fa100fdec59d7caebbe7a.1715753200.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-pion-stun-v2 and go-github-com-pion-mdns. | expand

Commit Message

Artyom V. Poptsov May 15, 2024, 6:17 a.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-pion-mdns): New variable.

Change-Id: Ic141fbaa01b40e60b443a672b5e54d315a114fff
---
 gnu/packages/golang-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 192b4e7cf1..ca9e88547e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3054,6 +3054,36 @@  (define-public go-github-com-pion-transport-v2
      (list
       #:import-path "github.com/pion/transport/v2"))))
 
+(define-public go-github-com-pion-mdns
+  (package
+    (name "go-github-com-pion-mdns")
+    (version "2.0.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pion/mdns/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "03675hx82lx3c8akkxdbkch1z4dbq54r05jk6jgdyd7mrdh9k4lm"))))
+    (build-system go-build-system)
+    (native-inputs (list go-github-com-stretchr-testify))
+    (propagated-inputs (list go-github-com-pion-logging
+                             go-github-com-pion-transport-v3
+                             go-golang-org-x-net))
+    (arguments
+     (list
+      #:go go-1.21
+      #:tests? #f ;Tests require network access.
+      #:import-path "github.com/pion/mdns"))
+    (home-page "https://github.com/pion/mdns/")
+    (synopsis "Pure Go implementation of Multicast DNS")
+    (description
+     "Pure Go implementation of Multicast DNS for @url{https://github.com/pion, Pion}
+WebRTC.")
+    (license license:expat)))
+
 (define-public go-github-com-prometheus-client-model
   (package
     (name "go-github-com-prometheus-client-model")