diff mbox series

[bug#65204,1/6] gnu: Add go-github-com-dgryski-go-metro.

Message ID ee3482b0b96a72f766cf141fce1eb87faeb75253.1691666406.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add go-github-com-tdewolff-hasher. | expand

Commit Message

Hilton Chain Aug. 10, 2023, 11:43 a.m. UTC
* gnu/packages/golang.scm (go-github-com-dgryski-go-metro): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ea6aadbe80..88c77db5f8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5246,6 +5246,30 @@  (define-public go-github-com-ayufan-golang-kardianos-service
 SysVinit, and more.")
       (license license:zlib))))
 
+(define-public go-github-com-dgryski-go-metro
+  (package
+    (name "go-github-com-dgryski-go-metro")
+    (version "0.0.0-20211217172704-adc40b04c140")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dgryski/go-metro")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "16y5vc5qf7aipi8basqza8l939hlmp7wqsv4y6gsqac3sp9ziqyj"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/dgryski/go-metro"))
+    (home-page "https://github.com/dgryski/go-metro")
+    (synopsis "Go translation of MetroHash")
+    (description
+     "This package provides a Go translation of the
+@url{https://github.com/jandrewrogers/MetroHash, reference C++ code for
+MetroHash}, a high quality, high performance hash algorithm.")
+    (license license:expat)))
+
 (define-public go-github-com-docker-distribution
   (let ((commit "325b0804fef3a66309d962357aac3c2ce3f4d329")
         (revision "0"))