diff mbox series

[bug#65204,2/6] gnu: Add go-github-com-dgryski-go-mph.

Message ID ce4f49c456d45dedff9861a1ed0e18f52486f6e0.1691666406.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add go-github-com-tdewolff-hasher. | expand

Commit Message

Hilton Chain Aug. 10, 2023, 11:43 a.m. UTC
* gnu/packages/golang.scm (go-github-com-dgryski-go-mph): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 88c77db5f8..016695239e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5270,6 +5270,30 @@  (define-public go-github-com-dgryski-go-metro
 MetroHash}, a high quality, high performance hash algorithm.")
     (license license:expat)))
 
+(define-public go-github-com-dgryski-go-mph
+  (package
+    (name "go-github-com-dgryski-go-mph")
+    (version "0.0.0-20211217222804-81a8625fb7ed")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dgryski/go-mph")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "10q8l4jdzqf54bnnxka2jk6qzayri3ijv51knn1n0iimfric8w9g"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/dgryski/go-mph"))
+    (propagated-inputs
+     (list go-github-com-dgryski-go-metro))
+    (home-page "https://github.com/dgryski/go-mph")
+    (synopsis "Go minimal perfect hash function")
+    (description
+     "This package implements a hash/displace minimal perfect hash function.")
+    (license license:expat)))
+
 (define-public go-github-com-docker-distribution
   (let ((commit "325b0804fef3a66309d962357aac3c2ce3f4d329")
         (revision "0"))