diff mbox series

[bug#68197,v2REVISION,4/5] gnu: Add python-websockets-12.

Message ID eb44de1436b4c65e74f0610de2bbd89b16c885c1.1704158704.git.jaeme@runbox.com
State New
Headers show
Series [bug#68197,v2REVISION,1/5] gnu: Add python-urllib3-2. | expand

Commit Message

Jaeme Sifat Jan. 2, 2024, 1:25 a.m. UTC
* gnu/packages/python-web.scm (python-websockets-12): New variable.

Change-Id: I5e4555098039d17db87f16f488e302cc27668898
---
 gnu/packages/python-web.scm | 36 +++++++++++++++++++++++++-----------
 1 file changed, 25 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 261277155a..2797f9ff49 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6336,8 +6336,32 @@  (define-public python-warcio
 files.")
       (license license:asl2.0))))
 
+(define-public python-websockets-12
+  (package
+    (name "python-websockets")
+    (version "12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "websockets" version))
+       (sha256
+        (base32 "06wbik9ksfbzafq0fla3r2pjvgpy3c0qrr87w3hhs9kcpfy9rpw1"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #f))
+    (home-page "https://github.com/aaugustin/websockets")
+    (synopsis
+     "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
+    (description
+     "@code{websockets} is a library for building WebSocket servers and clients
+in Python with a focus on correctness and simplicity.
+
+Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
+it provides an elegant coroutine-based API.")
+    (license license:bsd-3)))
+
 (define-public python-websockets
   (package
+    (inherit python-websockets-12)
     (name "python-websockets")
     (version "11.0.3")
     (source
@@ -6356,17 +6380,7 @@  (define-public python-websockets
            #~(modify-phases %standard-phases
                (add-before 'check 'extend-test-timeout
                  (lambda _
-                   (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))
-    (home-page "https://github.com/aaugustin/websockets")
-    (synopsis
-     "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
-    (description
-     "@code{websockets} is a library for building WebSocket servers and clients
-in Python with a focus on correctness and simplicity.
-
-Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
-it provides an elegant coroutine-based API.")
-    (license license:bsd-3)))
+                   (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))))
 
 (define-public python-selenium
   (package