diff mbox series

[bug#68197,v2REVISION,2/5] gnu: Add python-requests-2.31.

Message ID 3381e1e549e5aec6f4c8c95c98edbf4faa081f71.1704158703.git.jaeme@runbox.com
State New
Headers show
Series [bug#68197,v2REVISION,1/5] gnu: Add python-urllib3-2. | expand

Commit Message

Jaeme Sifat Jan. 2, 2024, 1:25 a.m. UTC
* gnu/packages/python-web.scm (python-requests-2.31): New variable.
* gnu/packages/python-web.scm (python-requests): Inherit from
python-requests-2.31.

Change-Id: I63aa988a03d198bbc010b56e8742b5d000caeaeb
---
 gnu/packages/python-web.scm | 30 +++++++++++++++++++++++-------
 1 file changed, 23 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cd5cac4f44..261277155a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3212,25 +3212,23 @@  (define-public python-beren
      "@code{beren} provides a REST client for Orthanc, a DICOM server.")
     (license license:gpl3+)))
 
-(define-public python-requests
+(define-public python-requests-2.31
   (package
     (name "python-requests")
-    (version "2.28.1")
+    (version "2.31.0")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri "requests" version))
              (sha256
               (base32
-               "10vrr7bijzrypvms3g2sgz8vya7f9ymmcv423ikampgy0aqrjmbw"))))
-    (build-system python-build-system)
+               "1qfidaynsrci4wymrw3srz8v1zy7xxpcna8sxpm91mwqixsmlb4l"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
      (list python-certifi
            python-charset-normalizer
            python-idna
            python-urllib3))
-    (arguments
-     ;; FIXME: Some tests require network access.
-     '(#:tests? #f))
+    (arguments (list #:tests? #f))
     (home-page "http://python-requests.org/")
     (synopsis "Python HTTP library")
     (description
@@ -3238,6 +3236,24 @@  (define-public python-requests
 than Python’s urllib2 library.")
     (license license:asl2.0)))
 
+(define-public python-requests
+  (package
+    (inherit python-requests-2.31)
+    (name "python-requests")
+    (version "2.28.1")
+    (source (origin
+             (method url-fetch)
+             (uri (pypi-uri "requests" version))
+             (sha256
+              (base32
+               "10vrr7bijzrypvms3g2sgz8vya7f9ymmcv423ikampgy0aqrjmbw"))))
+    (build-system python-build-system) ; Tests require network access.
+    (propagated-inputs
+     (list python-certifi
+           python-charset-normalizer
+           python-idna
+           python-urllib3))))
+
 (define-public python-requests-kerberos
   (package
     (name "python-requests-kerberos")