diff mbox series

[bug#66827,20/67] gnu: go-github-com-jcmturner-goidentity-v6: Adjust inputs.

Message ID e98697a41c67b235ebd31c0bfd84994f76f0ffd0.1699403992.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#66827,01/67] gnu: Add (gnu packages golang-web) module. | expand

Commit Message

Sharlatan Hellseher Nov. 8, 2023, 12:40 a.m. UTC
* gnu/packages/golang-web.scm (go-github-com-jcmturner-goidentity-v6):
[propagated-inputs]: Move go-github-com-stretchr-testify from here ...
[native-inputs]: ... to here.

Change-Id: I1e7bd72b3bf1c0879426a6a4c5b3b1de1d316069
---
 gnu/packages/golang-web.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 751eb41b58..8ced6a4c6f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -330,8 +330,10 @@  (define-public go-github-com-jcmturner-goidentity-v6
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/jcmturner/goidentity/v6"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
     (propagated-inputs
-     (list go-github-com-stretchr-testify go-github-com-hashicorp-go-uuid))
+     (list go-github-com-hashicorp-go-uuid))
     (home-page "https://github.com/jcmturner/goidentity")
     (synopsis "Hold authenticated identities and their attributes")
     (description "This package provides a standard interface for holding