diff mbox series

[bug#49859,1/6] gnu: Remove pidentd.

Message ID e874bdd3732a0423a9fa1c52f2996411ce08072c.1628040048.git.leo@famulari.name
State Accepted
Headers show
Series [bug#49859,1/6] gnu: Remove pidentd. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Aug. 4, 2021, 1:20 a.m. UTC
As discussed in <https://bugs.gnu.org/46602>, pidentd does not support a
current release of OpenSSL, and there does not seem to be any activity
upstream to improve that.

* gnu/packages/networking.scm (pidentd): Remove variable.
---
 gnu/packages/networking.scm | 27 ---------------------------
 1 file changed, 27 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 05fd092b23..212d4eac2f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2595,33 +2595,6 @@  enabled due to license conflicts between the BSD advertising clause and the GPL.
     ;; distribution for clarification.
     (license (list license:bsd-3 license:bsd-4))))
 
-(define-public pidentd
-  (package
-    (name "pidentd")
-    (version "3.0.19")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-              (url "https://github.com/ptrrkssn/pidentd")
-              (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "1k4rr0b4ygxssbnsykzjvz4hjhazzz4j5arlilyc1iq7b1wzsk7i"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:tests? #f)) ; No tests are included
-    (inputs
-     `(("openssl" ,openssl-1.0)))       ;for the DES library
-    (home-page "https://www.lysator.liu.se/~pen/pidentd/")
-    (synopsis "Small Ident Daemon")
-    (description
-     "@dfn{Pidentd} (Peter's Ident Daemon) is an identd, which implements a
-identification server.  Pidentd looks up specific TCP/IP connections and
-returns the user name and other information about the connection.")
-    (license license:public-domain)))
-
 (define-public spiped
   (package
     (name "spiped")