diff mbox series

[bug#49859,2/6] gnu: Remove cadaver.

Message ID 09d99994542520b463a469b45b8a67b500b177cc.1628040048.git.leo@famulari.name
State Accepted
Headers show
Series [bug#49859,1/6] gnu: Remove pidentd. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Aug. 4, 2021, 1:20 a.m. UTC
As discussed in <https://bugs.gnu.org/46602>, cadaver does not support a
current release of OpenSSL.

* gnu/packages/web.scm (cadaver): Remove variable.
---
 gnu/packages/web.scm | 32 --------------------------------
 1 file changed, 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 432ed3c445..24dd08d44f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6614,38 +6614,6 @@  file links.")
                    license:psfl               ; linkcheck/gzip2.py
                    license:expat))))          ; linkcheck/mem.py
 
-(define-public cadaver
-  (package
-    (name "cadaver")
-    (version "0.23.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://www.webdav.org/cadaver/"
-                           name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "1jizq69ifrjbjvz5y79wh1ny94gsdby4gdxwjad4bfih6a5fck7x"))))
-    (build-system gnu-build-system)
-    ;; TODO: Unbundle libneon and make build succeed with new neon.
-    (arguments
-     `(#:configure-flags (list "--with-ssl=openssl")
-       #:tests? #f)) ;No tests included
-    (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)))
-    (inputs
-     `(("expat" ,expat)
-       ("openssl" ,openssl-1.0)))
-    (home-page "http://www.webdav.org/cadaver/")
-    (synopsis "Command-line WebDAV client")
-    (description
-     "Cadaver is a command-line WebDAV client for Unix.  It supports
-file upload, download, on-screen display, namespace operations (move/copy),
-collection creation and deletion, and locking operations.")
-    (license license:gpl2)))
-
 (define-public castor
   (package
     (name "castor")