diff mbox series

[bug#64085,2/2] gnu: Add ansilove.

Message ID e699ddd3a1110e489e2ed75c6c9a65585f3e052e.1686848042.git.cairn@pm.me
State New
Headers show
Series Add ansilove. | expand

Commit Message

Cairn June 15, 2023, 5:52 p.m. UTC
* gnu/packages/image-processing.scm (ansilove): New variable.
---
 gnu/packages/image-processing.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 7eaa0eed67..3a846cbe25 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1763,3 +1763,28 @@  (define-public libansilove
 including ANSI (.ANS) and many others.  The library primarily serves to support
 the ansilove tool.")
     (license license:bsd-2)))
+
+(define-public ansilove
+  (package
+    (name "ansilove")
+    (version "4.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ansilove/ansilove")
+                    (commit (string-append version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1h9r759krjl8wi68yxs1d46qfrx6v89a8vmmv3aqym8vn9x430kh"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     (list libansilove))
+    (home-page "https://www.ansilove.org/")
+    (synopsis "ANSI and ASCII art to PNG converter")
+    (description
+     "AnsiLove is an ANSI and ASCII art to PNG converter, allowing to convert
+ANSI and artscene-related file formats into PNG images, supporting ANSI (.ANS),
+PCBoard (.PCB), Binary (.BIN), Artworx (.ADF), iCE Draw (.IDF), Tundra (.TND)
+and XBin (.XB) formats.")
+    (license license:bsd-2)))