diff mbox series

[bug#64085,1/2] gnu: Add libansilove.

Message ID 9cbbe2f48caa20862e0f5a093dfb6509759b000a.1686848042.git.cairn@pm.me
State New
Headers show
Series Add ansilove. | expand

Commit Message

Cairn June 15, 2023, 5:52 p.m. UTC
* gnu/packages/image-processing.scm (libansilove): New variable.
---
 gnu/packages/image-processing.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index f2ea6534f4..7eaa0eed67 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2023 Cairn <cairn@pm.me>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -63,6 +64,7 @@  (define-module (gnu packages image-processing)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages game-development)
   #:use-module (gnu packages gcc)
+  #:use-module (gnu packages gd)
   #:use-module (gnu packages geo)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gimp)
@@ -1735,3 +1737,29 @@  (define-public charls
  to have them encoded to JPEG-LS, or JPEG-LS streams, which CharLS will decode
 to images.")
     (license license:bsd-3)))
+
+(define-public libansilove
+  (package
+    (name "libansilove")
+    (version "1.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ansilove/libansilove")
+                    (commit (string-append version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "169njlck4a2bmf1kmjas1w594hyda543ykdnwg7fwkviij39l9z6"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f)) ; No tests included
+    (native-inputs
+     (list gd))
+    (home-page "https://www.ansilove.org/")
+    (synopsis "Library for converting ANSI, ASCII, and other formats to PNG")
+    (description
+     "libansilove is a library for converting artscene file types to PNG images,
+including ANSI (.ANS) and many others.  The library primarily serves to support
+the ansilove tool.")
+    (license license:bsd-2)))