diff mbox series

[bug#53531,1/2] WIP: qsyncthingtray: Use QtWebEngine instead of QtWebKit.

Message ID e698b441069f5cfca91b86c81b2577f19cb33e60.1643139447.git.leo@famulari.name
State Accepted
Headers show
Series [bug#53531,1/2] WIP: qsyncthingtray: Use QtWebEngine instead of QtWebKit. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Jan. 25, 2022, 7:37 p.m. UTC
This doesn't work. When trying to launch the web view from the tray
icon, QSyncthingTray crashes like this:

------
Could not find QtWebEngineProcess
Aborted
------

* gnu/packages/sync.scm (qsyncthingtray)[arguments]: Remove
Webkit-related argument from #:configure-flags.
[inputs]: Remove qtwebkit. Add qtdeclarative, qtwebchannel, and
qtwebengine.
---
 gnu/packages/sync.scm | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 165be17e4c..d9c91804b5 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -378,8 +378,7 @@  (define-public qsyncthingtray
           "1n9g4j7qznvg9zl6x163pi9f7wsc3x6q76i33psnm7x2v1i22x5w"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          ;; The program is meant to be run from the git repo or source tarball.
          (replace 'install
@@ -394,7 +393,7 @@  (define-public qsyncthingtray
                #t))))
        #:tests? #f)) ; no test target
     (inputs
-     (list qtbase-5 qtwebkit))
+     (list qtbase-5 qtdeclarative qtwebchannel qtwebengine))
     (home-page "https://github.com/sieren/QSyncthingTray")
     (synopsis "Traybar Application for Syncthing")
     (description