diff mbox series

[bug#53531,2/2] gnu: QSyncthingTray: Deprecate in favor of Debian's syncthing-gtk fork.

Message ID c56ca7faf46086cb3595f9a382b586badab18474.1643139447.git.leo@famulari.name
State Accepted
Headers show
Series [bug#53531,1/2] WIP: qsyncthingtray: Use QtWebEngine instead of QtWebKit. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Jan. 25, 2022, 7:37 p.m. UTC
This package is abandoned upstream and depends on the insecure and
abandoned QtWebKit.

Upstream abandonment:

https://github.com/sieren/QSyncthingTray/issues/247

See <https://issues.guix.gnu.org/53289> for more information about this change

* gnu/packages/sync.scm (qsyncthingtray): Move this variable ...
* gnu/packages/syncthing.scm (qsyncthingtray): ... to here. And make it into a
deprecated-package that points to syncthing-gtk.
---
 gnu/packages/sync.scm      | 51 --------------------------------------
 gnu/packages/syncthing.scm |  3 +++
 2 files changed, 3 insertions(+), 51 deletions(-)

Comments

Efraim Flashner Jan. 26, 2022, 9:42 a.m. UTC | #1
On Tue, Jan 25, 2022 at 02:37:27PM -0500, Leo Famulari wrote:
> This package is abandoned upstream and depends on the insecure and
> abandoned QtWebKit.
> 
> Upstream abandonment:
> 
> https://github.com/sieren/QSyncthingTray/issues/247
> 
> See <https://issues.guix.gnu.org/53289> for more information about this change

I like this idea. Although I'm not sure about keeping the first patch.
Leo Famulari Jan. 26, 2022, 6:03 p.m. UTC | #2
On Wed, Jan 26, 2022 at 11:42:05AM +0200, Efraim Flashner wrote:
> I like this idea. Although I'm not sure about keeping the first patch.

I forgot to mention: the first patch is just a demonstration of why
using QtWebEngine doesn't work "out of the box".
Leo Famulari Feb. 9, 2022, 4:58 p.m. UTC | #3
On Wed, Jan 26, 2022 at 11:42:05AM +0200, Efraim Flashner wrote:
> On Tue, Jan 25, 2022 at 02:37:27PM -0500, Leo Famulari wrote:
> > This package is abandoned upstream and depends on the insecure and
> > abandoned QtWebKit.
> > 
> > Upstream abandonment:
> > 
> > https://github.com/sieren/QSyncthingTray/issues/247
> > 
> > See <https://issues.guix.gnu.org/53289> for more information about this change
> 
> I like this idea. Although I'm not sure about keeping the first patch.

Pushed as 4578ad78bee1dfd450962627ae66d3e15ebadad2
diff mbox series

Patch

diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index d9c91804b5..db0e001658 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -362,57 +362,6 @@  (define-public owncloud-client
 silently and reliably flow across to every other.")
     (license license:gpl2+)))
 
-(define-public qsyncthingtray
-  (package
-    (name "qsyncthingtray")
-    (version "0.5.8")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/sieren/QSyncthingTray")
-               (commit version)))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "1n9g4j7qznvg9zl6x163pi9f7wsc3x6q76i33psnm7x2v1i22x5w"))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; The program is meant to be run from the git repo or source tarball.
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin")))
-               (install-file "QSyncthingTray" bin)
-               (mkdir-p (string-append out "/share/pixmaps"))
-               (copy-file "../source/resources/images/Icon1024.png"
-                          (string-append
-                            out "/share/pixmaps/QSyncthingTray.png"))
-               #t))))
-       #:tests? #f)) ; no test target
-    (inputs
-     (list qtbase-5 qtdeclarative qtwebchannel qtwebengine))
-    (home-page "https://github.com/sieren/QSyncthingTray")
-    (synopsis "Traybar Application for Syncthing")
-    (description
-     "A traybar application for syncthing.
-@enumerate
-@item Shows number of connections at a glance.
-@item Traffic statistics about incoming, outgoing and total throughput.
-@item Launches Syncthing and Syncthing-iNotifier if specified.
-@item Quickly pause Syncthing with one click.
-@item Last Synced Files - Quickly see the recently synchronised files and open
-their folder.
-@item Quick Access to all shared folders.
-@item Presents Syncthing UI in a separate view instead of using the browser.
-@item Supports authenticated HTTPS connections.
-@item Uses System Notifications about current connection status.
-@item Toggle for monochrome icon.
-@end enumerate\n")
-    (license license:lgpl3+)))
-
 (define-public lsyncd
   (package
     (name "lsyncd")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c19cc97862..c96d5cc3f2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -217,6 +217,9 @@  (define-public syncthing-gtk
 @end itemize\n")
       (license gpl2))))
 
+(define-public qsyncthingtray
+  (deprecated-package "qsyncthingtray" syncthing-gtk))
+
 (define-public go-github-com-jackpal-go-nat-pmp
   (package
     (name "go-github-com-jackpal-go-nat-pmp")