diff mbox series

[bug#63325] gnu: vulkan-loader: Only run tests on x86.

Message ID e69158062e0eba76d92762bd2439573cbd64b6ae.1683363858.git.mail@cbaines.net
State New
Headers show
Series [bug#63325] gnu: vulkan-loader: Only run tests on x86. | expand

Commit Message

Christopher Baines May 6, 2023, 9:04 a.m. UTC
* gnu/packages/vulkan.scm (vulkan-loader)[arguments]: Only run tests on x86.
---
 gnu/packages/vulkan.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)


base-commit: 64086a4fa449a9f6d2f835fcdf5498222b309e3a

Comments

Simon South May 8, 2023, 2:54 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:
> * gnu/packages/vulkan.scm (vulkan-loader)[arguments]: Only run tests on x86.

Christopher,

Disabling tests altogether seems extreme considering the only truly
x86-dependent ones appear to be five of the "TryLoadWrongBinaries" tests
(only these fail on AArch64), and this can perhaps be fixed by modifying
tests/framework/data/CMakeLists.txt to recreate the prebuilt binaries
included in the source package.

At any rate, I'd appreciate a day or two to see if I can come up with a
more nuanced patch that preserves the test suite on at least AArch64.
Simon South May 9, 2023, 8:53 p.m. UTC | #2
Simon South <simon@simonsouth.net> writes:
> At any rate, I'd appreciate a day or two to see if I can come up with
> a more nuanced patch that preserves the test suite on at least
> AArch64.

To avoid hijacking this issue further I've opened one of my own, #63400,
with a patch that disables only the x86-specific tests on non-x86
platforms.

https://issues.guix.gnu.org/63400

Christopher, does this fix things for you as well?  For which
architecture are you building?
Simon Tournier May 11, 2023, 12:59 p.m. UTC | #3
Hi,

On mar., 09 mai 2023 at 16:53, Simon South <simon@simonsouth.net> wrote:

> https://issues.guix.gnu.org/63400

I am in favor to close this submission and consider #63400.  Chris,
WDYT?

Cheers,
simon
Efraim Flashner May 15, 2023, 7:04 p.m. UTC | #4
On Thu, May 11, 2023 at 02:59:57PM +0200, Simon Tournier wrote:
> Hi,
> 
> On mar., 09 mai 2023 at 16:53, Simon South <simon@simonsouth.net> wrote:
> 
> > https://issues.guix.gnu.org/63400
> 
> I am in favor to close this submission and consider #63400.  Chris,
> WDYT?

Having come to basically the same patch (sorry Chris!) and having pushed
it, I'm going to close this patch and we can continue in 63400, which so
far has us skipping enough tests to pass on aarch64 but still fail on
other architectures.
Christopher Baines May 15, 2023, 8:16 p.m. UTC | #5
Efraim Flashner <efraim@flashner.co.il> writes:

> [[PGP Signed Part:Good signature from 41AAE7DCCA3D8351 Efraim Flashner <efraim@flashner.co.il> (trust undefined) created at 2023-05-15T20:04:37+0100 using RSA]]
> On Thu, May 11, 2023 at 02:59:57PM +0200, Simon Tournier wrote:
>> Hi,
>> 
>> On mar., 09 mai 2023 at 16:53, Simon South <simon@simonsouth.net> wrote:
>> 
>> > https://issues.guix.gnu.org/63400
>> 
>> I am in favor to close this submission and consider #63400.  Chris,
>> WDYT?
>
> Having come to basically the same patch (sorry Chris!) and having pushed
> it, I'm going to close this patch and we can continue in 63400, which so
> far has us skipping enough tests to pass on aarch64 but still fail on
> other architectures.

No worries, I wasn't planning to merge this before looking at #63400
anyway.
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index b0d968938b..f03c3dbc6f 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -228,8 +228,10 @@  (define-public vulkan-loader
     (build-system cmake-build-system)
     (arguments
      (list
-      #:tests? (not (or (%current-target-system)
-                        (target-riscv64?)))
+      ;; TODO: Some tests seem to assume running on x86,
+      ;; e.g. TryLoadWrongBinaries
+      #:tests? (and (target-x86?)
+                    (not (%current-target-system)))
       #:configure-flags
       #~(list (string-append "-DVULKAN_HEADERS_INSTALL_DIR="
                              (dirname (dirname