diff mbox series

[bug#70112,07/11] gnu: Add podman-compose.

Message ID e5159ec4fa61544e6d0a6ed55f259e0b59a70211.1711909824.git.~@wolfsden.cz
State New
Headers show
Series Update container tooling (podman, buildah) | expand

Commit Message

Tomas Volf March 31, 2024, 6:35 p.m. UTC
* gnu/packages/containers.scm (podman-compose): New variable.

Change-Id: Ieb5ee4b6e82464599a17ec950be8a7dbb2efa842
---
 gnu/packages/containers.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 36948cf5e2..faea15b8c4 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -34,6 +34,7 @@  (define-module (gnu packages containers)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
+  #:use-module (guix build-system python)
   #:use-module (guix utils)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages autotools)
@@ -49,6 +50,7 @@  (define-module (gnu packages containers)
   #:use-module (gnu packages python)
   #:use-module (gnu packages networking)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages rust-apps)
   #:use-module (gnu packages selinux)
   #:use-module (gnu packages version-control)
@@ -532,6 +534,34 @@  (define-public podman
 packaged.")
     (license license:asl2.0)))
 
+(define-public podman-compose
+  (package
+    (name "podman-compose")
+    (version "1.0.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/containers/podman-compose")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "11dwpifkm20vyi6r3fgmiiqc01mpm4r8l0p5gfh0bawi2gklrhsf"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:tests? #f))
+    (inputs (list python-dotenv
+                  python-pyyaml))
+    (home-page "https://github.com/containers/podman-compose")
+    (synopsis "Implementation of @url{https://compose-spec.io/,,Compose Spec}
+with @code{podman} backend")
+    (description "Provides an implementation of
+@url{https://compose-spec.io/,,Compose Spec} for @code{podman} focused on
+being rootless and not requiring any daemon to be running.")
+    (license license:gpl2)))
+
 (define-public buildah
   (package
     (name "buildah")