diff mbox series

[bug#70112,08/11] gnu: gvisor-tap-vsock: Remove references to go.

Message ID c30d670a2dcee20724f01d4685b3fda6d2fd1230.1711909824.git.~@wolfsden.cz
State New
Headers show
Series Update container tooling (podman, buildah) | expand

Commit Message

Tomas Volf March 31, 2024, 6:35 p.m. UTC
This is handled automatically by go-build-system, but (obviously) not by the
gnu-build-system, so add the phase manually.

* gnu/packages/containers.scm (gvisor-tap-vsock)[arguments]<#:phases>: Add
'remove-go-references phase.

Change-Id: I5cef0bc03dfa7f219bdfec4226d0e7772401a5a5
---
 gnu/packages/containers.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index faea15b8c4..992ef82d3f 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -26,6 +26,7 @@ 
 (define-module (gnu packages containers)
   #:use-module (guix gexp)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix modules)
   #:use-module (gnu packages)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -387,6 +388,9 @@  (define-public gvisor-tap-vsock
      (list
       #:make-flags `(list ,(string-append "GIT_VERSION=v" version))
       #:test-target "test"
+      #:imported-modules
+      (source-module-closure `(,@%gnu-build-system-modules
+                               (guix build go-build-system)))
       #:phases
       #~(modify-phases %standard-phases
           (delete 'configure)
@@ -400,7 +404,9 @@  (define-public gvisor-tap-vsock
               (invoke "rm" "-r" "test")))
           (replace 'install
             (lambda _
-              (install-file "bin/gvproxy" (string-append #$output "/bin")))))))
+              (install-file "bin/gvproxy" (string-append #$output "/bin"))))
+          (add-after 'install 'remove-go-references
+            (@@ (guix build go-build-system) remove-go-references)))))
     (native-inputs (list go-1.20))
     (home-page "https://github.com/containers/gvisor-tap-vsock")
     (synopsis "Network stack for virtualization based on gVisor")