diff mbox series

[bug#70305,2/5] gnu: coin3d: Use G-Expressions.

Message ID e50384824c7dfaf96d96ff730fa7f0fc3b494ee6.1712657465.git.jean@foundation.xyz
State New
Headers show
Series gnu: coin3d: Improve and update to 4.0.2. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 9, 2024, 10:22 a.m. UTC
* gnu/packages/graphics.scm (coin3d) <source>, <arguments>: Use
G-Expressions.

Change-Id: I79a77bda6fc919d9c3b80e77e38855824e81f6e6
---
 gnu/packages/graphics.scm | 32 +++++++++++++++-----------------
 1 file changed, 15 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ebbc705cfc..f866318289 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1967,28 +1967,26 @@  (define-public coin3d
         (base32 "1ayg0hl8wanhadahm5xbghghxw1qjwqbrs3dl3ngnff027hsyf8p"))
        (modules '((guix build utils)))
        (snippet
-        '(begin
-           ;; Delete binaries
-           (for-each delete-file
-                     '("cfg/csubst.exe"
-                       "cfg/wrapmsvc.exe"))
-           ;; Delete references to packaging tool cpack. Otherwise the build
-           ;; fails with "add_subdirectory given source "cpack.d" which is not
-           ;; an existing directory."
-           (substitute* "CMakeLists.txt"
-             ((".*cpack.d.*") ""))
-           #t))))
+        #~(begin
+            ;; Delete binaries
+            (for-each delete-file
+                      '("cfg/csubst.exe"
+                        "cfg/wrapmsvc.exe"))
+            ;; Delete references to packaging tool cpack. Otherwise the build
+            ;; fails with "add_subdirectory given source "cpack.d" which is not
+            ;; an existing directory."
+            (substitute* "CMakeLists.txt"
+              ((".*cpack.d.*") ""))))))
     (build-system cmake-build-system)
+    (arguments
+     (list #:configure-flags
+           #~(list "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
+                   (string-append "-DBOOST_ROOT="
+                                  #$(this-package-input "boost")))))
     (native-inputs
      (list doxygen graphviz))
     (inputs
      (list boost freeglut glew))
-    (arguments
-     `(#:configure-flags
-       (list
-        "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
-        (string-append "-DBOOST_ROOT="
-                       (assoc-ref %build-inputs "boost")))))
     (home-page "https://github.com/coin3d/coin")
     (synopsis
      "High-level 3D visualization library with Open Inventor 2.1 API")