diff mbox series

[bug#70305,3/5] gnu: coin3d: Use system expat.

Message ID 7137561dd15207078db943555e392a3ba876d548.1712657465.git.jean@foundation.xyz
State New
Headers show
Series gnu: coin3d: Improve and update to 4.0.2. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 9, 2024, 10:22 a.m. UTC
* gnu/packages/graphics.scm (coin3d): Remove bundled expat and use the
system one.

Change-Id: Ief176e320b7f57c5c3f349f244ed7d76e54f8281
---
 gnu/packages/graphics.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f866318289..7f704c3e58 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1972,6 +1972,10 @@  (define-public coin3d
             (for-each delete-file
                       '("cfg/csubst.exe"
                         "cfg/wrapmsvc.exe"))
+            ;; Unbundle expat.
+            (delete-file-recursively "src/xml/expat")
+            (substitute* "src/xml/document.cpp"
+              (("expat/expat\\.h") "expat.h"))
             ;; Delete references to packaging tool cpack. Otherwise the build
             ;; fails with "add_subdirectory given source "cpack.d" which is not
             ;; an existing directory."
@@ -1981,12 +1985,13 @@  (define-public coin3d
     (arguments
      (list #:configure-flags
            #~(list "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
+                   "-DUSE_EXTERNAL_EXPAT=ON"
                    (string-append "-DBOOST_ROOT="
                                   #$(this-package-input "boost")))))
     (native-inputs
      (list doxygen graphviz))
     (inputs
-     (list boost freeglut glew))
+     (list boost expat freeglut glew))
     (home-page "https://github.com/coin3d/coin")
     (synopsis
      "High-level 3D visualization library with Open Inventor 2.1 API")