diff mbox series

[bug#54260,1/3] gnu: ucsim: Don't run tests when cross-compiling.

Message ID e45aa3e4c685d44ad2dd9c2c224451f06d8fb518.1646484354.git.simon@simonsouth.net
State Accepted
Headers show
Series gnu: ucsim: Update to 0.7.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon South March 5, 2022, 12:58 p.m. UTC
* gnu/packages/embedded.scm (ucsim)[arguments]: Skip tests when
cross-compiling.
---
 gnu/packages/embedded.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

M March 5, 2022, 3:21 p.m. UTC | #1
Simon South schreef op za 05-03-2022 om 07:58 [-0500]:
> +       #:tests? ,(not (%current-target-system)) ; run unless cross-compiling

#:tests? is #false by default when cross-compiling and #true by default
when compiling natively (with some exceptions, e.g. emacs-build-
system).  You probably don't need to set this explicitly.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index f7573618b9..43fba510da 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1501,6 +1501,7 @@  (define-public ucsim
                            "--enable-m6809-port"
                            "--enable-p1516-port"
                            "--enable-st7-port")
+       #:tests? ,(not (%current-target-system)) ; run unless cross-compiling
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-makefiles