diff mbox series

[bug#70693,v3,1/3] gnu: nss/fixed: Tweak performance test.

Message ID e18f8abc59798e33072b959b3ccb8e60111d630b.1715265342.git.mail@cbaines.net
State New
Headers show
Series [bug#70693,v3,1/3] gnu: nss/fixed: Tweak performance test. | expand

Commit Message

Christopher Baines May 9, 2024, 2:35 p.m. UTC
As I'm seeing this test fail with results of 5 to 7 seconds.

* gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
time threshold.

Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
---
 gnu/packages/nss.scm | 8 ++++++++
 1 file changed, 8 insertions(+)


base-commit: cf5f7a8bf9ca2288700fcf351bbca0fc341ec969

Comments

Ludovic Courtès May 13, 2024, 8:58 a.m. UTC | #1
Hi!

LGTM to me, please push!

Ludo’.
Christopher Baines May 13, 2024, 12:44 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi!
>
> LGTM to me, please push!

Things are building, so I've pushed this to master as
7b0f145802f0c2c785014293d748721678fef824.
diff mbox series

Patch

diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..80bf627583 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@  (define-public nss/fixed
                          (setenv "USE_IP" "TRUE")
                          (setenv "IP_ADDRESS" "127.0.0.1")
 
+                         ;; This specific test is looking at performance "now
+                         ;; verify that we can quickly dump a database", and
+                         ;; we're not testing performance here (especially
+                         ;; since we're using faketime), so raise the
+                         ;; threshold
+                         (substitute* "nss/tests/dbtests/dbtests.sh"
+                           ((" -lt 5") " -lt 50"))
+
                          ;; The "PayPalEE.cert" certificate expires every six months,
                          ;; leading to test failures:
                          ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>.  To