diff mbox series

[bug#70693,v3,2/3] gnu: Add po4a-minimal.

Message ID 3a9488a476a1cb365892f433342360d7dff776c7.1715265342.git.mail@cbaines.net
State New
Headers show
Series [bug#70693,v3,1/3] gnu: nss/fixed: Tweak performance test. | expand

Commit Message

Christopher Baines May 9, 2024, 2:35 p.m. UTC
The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
nss, which has a very time consuming testsuite.

* gnu/packages/gettext.scm (po4a-minimal): New variable.

Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4
---
 gnu/packages/gettext.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 1408cc4cb4..31fe95f6ad 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -317,3 +317,15 @@  (define-public po4a
 more interestingly, the maintenance of translations) using gettext tools on
 areas where they were not expected like documentation.")
     (license gpl2+)))
+
+(define-public po4a-minimal
+  (package/inherit po4a
+    (native-inputs
+     ;; Remove test dependencies, primarily to reduce the size of the
+     ;; dependency graph of the ‘guix’ package.
+     (modify-inputs (package-native-inputs po4a)
+       (delete "docbook-xml" "perl-test-pod" "texlive-updmap.cfg")))
+    (arguments
+     (substitute-keyword-arguments (package-arguments po4a)
+       ((#:tests? _ #t) #f)))
+    (properties '((hidden? . #t)))))