diff mbox series

[bug#63416,v2,2/2] gnu: gcc: Change make-gccgo to use gexp's.

Message ID de83ece2d58d7f55c28b2e74c46e252b94b66086.1683816850.git.mail@cbaines.net
State New
Headers show
Series [bug#63416,v2,1/2] gnu: gcc: Change custom-gcc to use gexp's. | expand

Commit Message

Christopher Baines May 11, 2023, 2:54 p.m. UTC
As otherwise this seems to generate broken derivations for i586-gnu.

* gnu/packages/gcc.scm (make-gccgo): Use gexp's for the package arguments.
---
 gnu/packages/gcc.scm | 56 ++++++++++++++++++++++----------------------
 1 file changed, 28 insertions(+), 28 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1db37529f7..1b444c2b02 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1156,34 +1156,34 @@  (define (make-gccgo gcc)
       (arguments
        (substitute-keyword-arguments (package-arguments gccgo)
          ((#:phases phases)
-          `(modify-phases ,phases
-             (add-after 'install 'wrap-go-with-tool-path
-               (lambda* (#:key outputs #:allow-other-keys)
-                 (let* ((out (assoc-ref outputs "out"))
-                        (exedir (string-append out "/libexec/gcc"))
-                        (tooldir (dirname (car (find-files exedir "^cgo$")))))
-                   (wrap-program (string-append out "/bin/go")
-                     `("GCCGOTOOLDIR" =
-                       (,(string-append "${GCCGOTOOLDIR:-" tooldir "}")))
-                     `("GOROOT" =
-                       (,(string-append "${GOROOT:-" out "}")))))))
-             (add-before 'configure 'fix-gotools-runpath
-               (lambda _
-                 (substitute* "gotools/Makefile.in"
-                   (("AM_LDFLAGS =" all)
-                    (string-append all " -Wl,-rpath=$(libdir) ")))))
-             (add-before 'configure 'remove-tool-reference-from-libgo
-               (lambda _
-                 (substitute* "libgo/Makefile.in"
-                   (("(GccgoToolDir = \\\")[^\\\"]+" _ start)
-                    (string-append start "/nonexistent"))
-                   ,@(if (version>=? (package-version gccgo) "12.0")
-                       '((("(defaultGOROOT = `)[^`]+" _ start)
-                          (string-append start "/nonexistent")))
-                       '((("(DefaultGoroot = \\\")[^\\\"]+" _ start)
-                          (string-append start "/nonexistent"))))
-                   (("(defaultGOROOTValue.*?return `)[^`]+" _ start)
-                    (string-append start "/nonexistent"))))))))))))
+          #~(modify-phases #$phases
+              (add-after 'install 'wrap-go-with-tool-path
+                (lambda* (#:key outputs #:allow-other-keys)
+                  (let* ((out (assoc-ref outputs "out"))
+                         (exedir (string-append out "/libexec/gcc"))
+                         (tooldir (dirname (car (find-files exedir "^cgo$")))))
+                    (wrap-program (string-append out "/bin/go")
+                      `("GCCGOTOOLDIR" =
+                        (,(string-append "${GCCGOTOOLDIR:-" tooldir "}")))
+                      `("GOROOT" =
+                        (,(string-append "${GOROOT:-" out "}")))))))
+              (add-before 'configure 'fix-gotools-runpath
+                (lambda _
+                  (substitute* "gotools/Makefile.in"
+                    (("AM_LDFLAGS =" all)
+                     (string-append all " -Wl,-rpath=$(libdir) ")))))
+              (add-before 'configure 'remove-tool-reference-from-libgo
+                (lambda _
+                  (substitute* "libgo/Makefile.in"
+                    (("(GccgoToolDir = \\\")[^\\\"]+" _ start)
+                     (string-append start "/nonexistent"))
+                    #$@(if (version>=? (package-version gccgo) "12.0")
+                           '((("(defaultGOROOT = `)[^`]+" _ start)
+                              (string-append start "/nonexistent")))
+                           '((("(DefaultGoroot = \\\")[^\\\"]+" _ start)
+                              (string-append start "/nonexistent"))))
+                    (("(defaultGOROOTValue.*?return `)[^`]+" _ start)
+                     (string-append start "/nonexistent"))))))))))))
 
 (define-public gccgo-4.9
   (custom-gcc (package