diff mbox series

[bug#63416,v2,1/2] gnu: gcc: Change custom-gcc to use gexp's.

Message ID 0c9c655159c65003e63d7ddc9f69a87608ae7ccd.1683816850.git.mail@cbaines.net
State New
Headers show
Series [bug#63416,v2,1/2] gnu: gcc: Change custom-gcc to use gexp's. | expand

Commit Message

Christopher Baines May 11, 2023, 2:54 p.m. UTC
As this seems to be generating broken derivations for i586-gnu otherwise.

* gnu/packages/gcc.scm (custom-gcc): Use gexp's for the generated package
arguments.
---
 gnu/packages/gcc.scm | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)


base-commit: 4557c83a7d9df6edc9dd3b7b2a53e1a0ec3e6e34
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 47fb443155..1db37529f7 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1043,18 +1043,18 @@  (define* (custom-gcc gcc name languages
           (srfi srfi-26)
           (ice-9 regex)))
        ((#:configure-flags flags)
-        `(cons (string-append "--enable-languages="
-                              ,(string-join languages ","))
-               (remove (cut string-match "--enable-languages.*" <>)
-                       ,flags)))
+        #~(cons (string-append "--enable-languages="
+                               #$(string-join languages ","))
+                (remove (cut string-match "--enable-languages.*" <>)
+                        #$flags)))
        ((#:phases phases)
-        `(modify-phases ,phases
-           (add-after 'install 'remove-broken-or-conflicting-files
-             (lambda* (#:key outputs #:allow-other-keys)
-               (for-each
-                delete-file
-                (find-files (string-append (assoc-ref outputs "out") "/bin")
-                            ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
+        #~(modify-phases #$phases
+            (add-after 'install 'remove-broken-or-conflicting-files
+              (lambda* (#:key outputs #:allow-other-keys)
+                (for-each
+                 delete-file
+                 (find-files (string-append (assoc-ref outputs "out") "/bin")
+                             ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
 
 (define %generic-search-paths
   ;; This is the language-neutral search path for GCC.  Entries in $CPATH are