diff mbox series

[bug#65336,2/2] gnu: looking-glass-client: Update package style.

Message ID dd4c012264d5f45ed89464ed9afd799f6aada160.1692176991.git.a.r.draidi@redscript.org
State New
Headers show
Series Update looking-glass-client to B6 and restyle package | expand

Commit Message

Ahmad Draidi Aug. 16, 2023, 9:32 a.m. UTC
* gnu/packages/virtualization.scm (looking-glass-client): Restyle format.
[arguments]: Use G-expressions.  Drop trailing #t from phases.
---
 gnu/packages/virtualization.scm | 142 ++++++++++++++++----------------
 1 file changed, 69 insertions(+), 73 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index e446adfa98..2f2454e544 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1918,84 +1918,80 @@  (define-public looking-glass-client
   (package
     (name "looking-glass-client")
     (version "B6")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://looking-glass.io/artifact/"
-                           version "/source"))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "15d7wwbzfw28yqbz451b6n33ixy50vv8acyzi8gig1mq5a8gzdib"))))
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://looking-glass.io/artifact/" version
+                                  "/source"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "15d7wwbzfw28yqbz451b6n33ixy50vv8acyzi8gig1mq5a8gzdib"))))
     (build-system cmake-build-system)
-    (inputs
-     (list bash-minimal
-           font-dejavu
-           fontconfig
-           freetype
-           glu
-           gmp
-           libglvnd
-           libiberty
-           libsamplerate
-           libx11
-           libxcursor
-           libxfixes
-           libxi
-           libxinerama
-           libxkbcommon
-           libxpresent
-           libxrandr
-           libxscrnsaver
-           mesa
-           pipewire
-           pulseaudio
-           spice-protocol
-           wayland
-           wayland-protocols
-           `(,zlib "static")))
+    (inputs (list bash-minimal
+                  font-dejavu
+                  fontconfig
+                  freetype
+                  glu
+                  gmp
+                  libglvnd
+                  libiberty
+                  libsamplerate
+                  libx11
+                  libxcursor
+                  libxfixes
+                  libxi
+                  libxinerama
+                  libxkbcommon
+                  libxpresent
+                  libxrandr
+                  libxscrnsaver
+                  mesa
+                  pipewire
+                  pulseaudio
+                  spice-protocol
+                  wayland
+                  wayland-protocols
+                  `(,zlib "static")))
     (native-inputs (list nettle pkg-config))
     (arguments
-     `(#:tests? #f ;; No tests are available.
-       ;; Package uses "-march=native" by default. We disable that to build with the
-       ;; lowest supported architecture for reproducibility and CPU compatibility.
-       #:configure-flags '("-DOPTIMIZE_FOR_NATIVE=OFF")
-       #:make-flags '("CC=gcc")
-       #:phases (modify-phases %standard-phases
-                  (add-before 'configure 'chdir-to-client
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (chdir "client")
-                      #t))
-                  (replace 'install
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (install-file "looking-glass-client"
-                                    (string-append (assoc-ref outputs "out")
-                                                   "/bin"))
-                      #t))
-                  (add-after 'install 'wrapper
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (wrap-program
-                          (string-append (assoc-ref outputs "out")
-                                         "/bin/looking-glass-client")
-                        `("LD_LIBRARY_PATH" ":" prefix
-                          ,(map (lambda (name)
-                                  (let ((input (assoc-ref inputs name)))
-                                    (string-append input "/lib")))
-                                '("gmp"
-                                  "libxi"
-                                  "nettle"
-                                  "mesa"
-                                  "wayland"
-                                  "fontconfig-minimal"
-                                  "freetype"
-                                  "libx11"
-                                  "libxfixes"
-                                  "libxscrnsaver"
-                                  "libxinerama"))))
-                      #t)))))
+     (list #:tests? #f ;No tests are available.
+           ;; Package uses "-march=native" by default. We disable that to build with the
+           ;; lowest supported architecture for reproducibility and CPU compatibility.
+           #:configure-flags #~'("-DOPTIMIZE_FOR_NATIVE=OFF")
+           #:make-flags #~'("CC=gcc")
+           #:phases #~(modify-phases %standard-phases
+                        (add-before 'configure 'chdir-to-client
+                          (lambda* (#:key outputs #:allow-other-keys)
+                            (chdir "client")))
+                        (replace 'install
+                          (lambda* (#:key outputs #:allow-other-keys)
+                            (install-file "looking-glass-client"
+                                          (string-append (assoc-ref outputs
+                                                                    "out")
+                                                         "/bin"))))
+                        (add-after 'install 'wrapper
+                          (lambda* (#:key inputs outputs #:allow-other-keys)
+                            (wrap-program (string-append (assoc-ref outputs
+                                                                    "out")
+                                           "/bin/looking-glass-client")
+                              `("LD_LIBRARY_PATH" ":" prefix
+                                ,(map (lambda (name)
+                                        (let ((input (assoc-ref inputs name)))
+                                          (string-append input "/lib")))
+                                      '("gmp" "libxi"
+                                        "nettle"
+                                        "mesa"
+                                        "wayland"
+                                        "fontconfig-minimal"
+                                        "freetype"
+                                        "libx11"
+                                        "libxfixes"
+                                        "libxscrnsaver"
+                                        "libxinerama")))))))))
     (home-page "https://looking-glass.io/")
     (synopsis "KVM Frame Relay (KVMFR) implementation")
-    (description "Looking Glass allows the use of a KVM (Kernel-based Virtual
+    (description
+     "Looking Glass allows the use of a KVM (Kernel-based Virtual
 Machine) configured for VGA PCI Pass-through without an attached physical
 monitor, keyboard or mouse.  It displays the VM's rendered contents on your
 main monitor/GPU.")