diff mbox series

[bug#47968,2/2] gnu: Add git-filter-repo

Message ID dd3b9d2@noop.avalenn.eu
State Accepted
Headers show
Series Add git-filter-repo | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

François April 23, 2021, 7:17 a.m. UTC
I use release tarball (instead of git as I would have liked) because it
contains pre-compiled man-pages which are too hard to build in this
context as it uses git Makefile to do it.

* gnu/packages/version-control.scm (git-filter-repo): New variable.

Signed-off-by: François J <francois-oss@avalenn.eu>
---
 gnu/packages/version-control.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Ludovic Courtès May 3, 2021, 4:41 p.m. UTC | #1
Hi François,

François J <francois-oss@avalenn.eu> skribis:

> I use release tarball (instead of git as I would have liked) because it
> contains pre-compiled man-pages which are too hard to build in this
> context as it uses git Makefile to do it.
>
> * gnu/packages/version-control.scm (git-filter-repo): New variable.
>
> Signed-off-by: François J <francois-oss@avalenn.eu>

Could you add a copyright line for you at the top?

> +        (base32
> +         "00nn7k9jqrybb762486fmigsnbcn9lbvimgpfvvarz4ikdp9y9pb"))
> +       ))

‘guix lint’ complains about these dangling parens.  :-)

> +    (arguments
> +     `(#:install-plan
> +       '(
> +         ("git-filter-repo" "libexec/git-core/")

Please move this to the previous line.

> +         ("Documentation/man1/" "share/man/man1")
> +         ("/" "" #:include ())
> +         )))

Likewise: lonely parens.  :-)

> +    (synopsis
> +     "Quickly rewrite git repository history")
> +    (description
> +     "Quickly rewrite git repository history")

Please capitalize “Git” and expound the description, using full
sentences, as per:

  https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html

Could you send an updated patch?

(The patch 1/2 LGTM.)

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index fddabbcd40..481cbbb98c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3074,3 +3074,34 @@  If several repos are related, it helps to see their status together.")
 makes a directory under a specific root directory (by default @file{~/ghq})
 using the remote repository URL's host and path.")
     (license license:expat)))
+
+(define-public git-filter-repo
+  (package
+    (name "git-filter-repo")
+    (version "2.29.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/newren/git-filter-repo/releases/"
+                           "download/v" version
+                           "/git-filter-repo-" version ".tar.xz"))
+       (sha256
+        (base32
+         "00nn7k9jqrybb762486fmigsnbcn9lbvimgpfvvarz4ikdp9y9pb"))
+       ))
+    (build-system copy-build-system)
+    (arguments
+     `(#:install-plan
+       '(
+         ("git-filter-repo" "libexec/git-core/")
+         ("Documentation/man1/" "share/man/man1")
+         ("/" "" #:include ())
+         )))
+    (home-page
+     "https://github.com/newren/git-filter-repo")
+    (synopsis
+     "Quickly rewrite git repository history")
+    (description
+     "Quickly rewrite git repository history")
+    (license (list license:expat ;; Main license.
+                   license:gpl2)))) ;; For test harness.