diff mbox series

[bug#47968,1/2] gnu: git: add a comment on why we don't build manpages

Message ID 0849d63@noop.avalenn.eu
State Accepted
Headers show
Series Add git-filter-repo | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

François April 23, 2021, 7:05 a.m. UTC
* gnu/packages/version-control.scm (git)[native-inputs]:
    add back comment skipped by commit
    d1cada0450fca54260fd20ab49d0586d147cbeb3

Signed-off-by: François J. <francois-oss@avalenn.eu>
---
 gnu/packages/version-control.scm | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3992f74644..fddabbcd40 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -188,6 +188,9 @@  as well as the classic centralized workflow.")
       ("bash" ,bash-minimal)
       ("bash-for-tests" ,bash)
       ("gettext" ,gettext-minimal)
+      ;; To build the man pages from the git sources, we would need a dependency
+      ;; on a full XML tool chain, and building it actually takes ages.  So we
+      ;; use this lazy approach and use released tarball.
       ("git-manpages"
        ,(origin
           (method url-fetch)