diff mbox series

[bug#69461,mesa-updates,v3,05/13] gnu: shaderc: Update to 2024.0.

Message ID dc368526d4752d4f0b4aa276ee8b8ac9af986c6e.1711561863.git.i@dan.games
State New
Headers show
Series Update vulkan-sdk to 1.3.280.0 and add directx-shader-compiler. | expand

Commit Message

dan March 28, 2024, 3:54 a.m. UTC
* gnu/packages/vulkan.scm (shaderc): Update to 2024.0.
  [arguments]<#:configure-flags>: Specify python executable.
  <#:phases>: Remove drop-additional-glslang-deps phase.
  [inputs]: Remove python.
  [native-inputs]: Add python.

Change-Id: I3ca4b6560288f4b8ea9440a7fd0a7815b67471d8
---
 gnu/packages/vulkan.scm | 24 ++++++++++--------------
 1 file changed, 10 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 038a896803..ef6e4b454f 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -359,7 +359,7 @@  (define-public shaderc
   (package
     (name "shaderc")
     ;; shaderc doesn't follow the versioning scheme of vulkan sdk
-    (version "2022.3")
+    (version "2024.0")
     (source
      (origin
        (method git-fetch)
@@ -369,13 +369,18 @@  (define-public shaderc
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0sdbfi66zmqj0c5q5yv2zvcvry7557yzgxk2mwflyjgqh7kdhb8d"))))
+         "1m5jncn6y8c6g83f8nwh86hz33mvv03x7fyr5zq0ynwanrcpn2hb"))))
     (build-system cmake-build-system)
     (arguments
      `(;; FIXME: Skip most of the tests, because enabling system gtest breaks
        ;; the build: <https://github.com/google/shaderc/issues/470>.
        #:configure-flags
        (list "-DSHADERC_SKIP_TESTS=ON"
+             ;; The two flags are copied from:
+             ;; https://sdk.lunarg.com/sdk/download/1.3.280.0/linux/config.json
+             "-DSHADERC_ENABLE_SHARED_CRT=ON"
+             "-DSHADERC_SKIP_COPYRIGHT_CHECK=ON"
+             "-DPYTHON_EXECUTABLE=python3"
              ;; Note: despite the name, this just specifies the headers.
              (string-append "-Dglslang_SOURCE_DIR="
                             (assoc-ref %build-inputs "glslang") "/include/glslang"))
@@ -401,20 +406,11 @@  (define-public shaderc
                          ,version
                          ,(package-version spirv-tools)
                          ,(package-version glslang))))
-             #t))
-         ;; see: https://github.com/google/shaderc/pull/1276
-         (add-after 'do-not-look-for-bundled-sources 'drop-additional-glslang-deps
-           (lambda _
-             (substitute* "glslc/CMakeLists.txt"
-               (("OSDependent OGLCompiler") ""))
-             (substitute* "libshaderc/CMakeLists.txt"
-               (("OSDependent OGLCompiler") ""))
-             (substitute* "libshaderc_util/CMakeLists.txt"
-               (("OSDependent OGLCompiler") "")))))))
+             #t)))))
     (inputs
-     (list glslang python spirv-headers spirv-tools))
+     (list glslang spirv-headers spirv-tools))
     (native-inputs
-     (list pkg-config))
+     (list pkg-config python))
     (home-page "https://github.com/google/shaderc")
     (synopsis "Tools for shader compilation")
     (description "Shaderc is a collection of tools, libraries, and tests for