diff mbox series

[bug#69461,mesa-updates,v3,09/13] gnu: vulkan-tools: Update to 1.3.280.0.

Message ID 28d6db476c6a195925f0b4d2866facacefdec770.1711561863.git.i@dan.games
State New
Headers show
Series Update vulkan-sdk to 1.3.280.0 and add directx-shader-compiler. | expand

Commit Message

dan March 28, 2024, 3:54 a.m. UTC
* gnu/packages/vulkan.scm (vulkan-tools): Update to 1.3.280.0.
  [arguments]: Turn on tests.
  [arguments]<:#configure-flags>: Remove GLSLANG_INSTALL_DIR.
  [native-inputs]: Add googletest.

Change-Id: Iadf98fc95d0d70c3780159992ebc2fdff6a2d108
---
 gnu/packages/vulkan.scm | 22 +++++++++++++++-------
 1 file changed, 15 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index c6d3d3d347..dfd8f73d9b 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -326,26 +326,34 @@  (define-public vulkan-loader
 (define-public vulkan-tools
   (package
     (name "vulkan-tools")
-    (version %vulkan-sdk-version)
+    (version "1.3.280.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/KhronosGroup/Vulkan-Tools")
-             (commit version)))
+             (commit (string-append "vulkan-sdk-" version))))
        (file-name (git-file-name name version))
+       (modules '((guix build utils)))
+       (snippet #~(substitute* "tests/icd/mock_icd_tests.cpp"
+                    ;; Disable driver info test since it relies on git branch info
+                    (("ASSERT_EQ\\(std::string\\(driver_properties\\.driverInfo\\)")
+                     "// ASSERT_EQ(std::string(driver_properties.driverInfo)")))
        (sha256
         (base32
-         "0jzwjfx4c7y15wkwfhhc64rzljpi47bxrm5jw5blfsqjh8zsd27a"))))
+         "0w0m04vscr4a6vr682g3mn7mfni740cmai9ylzlgfdggb77y58xz"))))
     (build-system cmake-build-system)
     (inputs
      (list glslang libxrandr vulkan-loader wayland wayland-protocols))
     (native-inputs
-     (list pkg-config python vulkan-headers))
+     (list googletest pkg-config python volk vulkan-headers))
     (arguments
-     `(#:tests? #f                      ;no tests
-       #:configure-flags (list (string-append "-DGLSLANG_INSTALL_DIR="
-                               (assoc-ref %build-inputs "glslang")))))
+     `(#:configure-flags (list "-DBUILD_TESTS=ON")
+       #:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "./tests/vulkan_tools_tests")))))))
     (home-page
      "https://github.com/KhronosGroup/Vulkan-Tools")
     (synopsis "Tools and utilities for Vulkan")