diff mbox series

[bug#46873,1/2] gnu: knot-resolver: Ensure all custom phases return #t on success.

Message ID da92549ffd4f17be006ddb45366657ff729a3aac.1614691387.git.simon@simonsouth.net
State Accepted
Headers show
Series gnu: knot-resolver: Fix phase return value; update to 5.3.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon South March 2, 2021, 1:53 p.m. UTC
* gnu/packages/dns.scm (knot-resolver)[arguments]<#:phases>: Return #t from
"move-doc" phase on success.
---
 gnu/packages/dns.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Tobias Geerinckx-Rice March 2, 2021, 2:22 p.m. UTC | #1
Simon South 写道:
> * gnu/packages/dns.scm (knot-resolver)[arguments]<#:phases>: 
> Return #t from
> "move-doc" phase on success.

Thanks, but I don't think this is worth the noise at this point: 
that requirement will be gone on the next core-updates merge, and 
there will be much rejoicing.

The update itself LGTM; I'll test it now.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 2c4008559f..5b0e310a0c 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -979,7 +979,8 @@  synthesis, and on-the-fly re-configuration.")
                                (string-append doc "/share/" dir)))
                 '("doc/knot-resolver/examples"
                   "doc/knot-resolver/html"
-                  "info")))))
+                  "info"))
+               #t)))
          (add-after 'install 'wrap-binary
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))