diff mbox series

[bug#49221,08/13] gnu: earlyoom: Patch tests for go-1.16.

Message ID d87a3ee5609501d82a1cd386301bb4a10011d3c1.1624602942.git.iskarian@mgsn.dev
State Accepted
Headers show
Series Add go-1.16 and build with gccgo | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen June 25, 2021, 7:21 a.m. UTC
* gnu/packages/patches/earlyoom-1.6.2-disable-go-module.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/linux.scm (earlyoom): Use it.
---
 gnu/local.mk                                    |  1 +
 gnu/packages/linux.scm                          |  4 +++-
 .../earlyoom-1.6.2-disable-go-module.patch      | 17 +++++++++++++++++
 3 files changed, 21 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/earlyoom-1.6.2-disable-go-module.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 509970f044..9caae52306 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -968,6 +968,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/dstat-skip-devices-without-io.patch	\
   %D%/packages/patches/dune-istl-2.7-fix-non-mpi-tests.patch	\
   %D%/packages/patches/dvd+rw-tools-add-include.patch 		\
+  %D%/packages/patches/earlyoom-1.6.2-disable-go-module.patch	\
   %D%/packages/patches/ecl-16-format-directive-limit.patch	\
   %D%/packages/patches/ecl-16-ignore-stderr-write-error.patch	\
   %D%/packages/patches/ecl-16-libffi.patch			\
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 65f9057077..1f0b4cdb8e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -53,6 +53,7 @@ 
 ;;; Copyright © 2020 David Dashyan <mail@davie.li>
 ;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
 ;;; Copyright © 2021 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3393,7 +3394,8 @@  from the module-init-tools project.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "16iyn51xlrsbshc7p5xl2338yyfzknaqc538sa7mamgccqwgyvvq"))))
+                "16iyn51xlrsbshc7p5xl2338yyfzknaqc538sa7mamgccqwgyvvq"))
+              (patches (search-patches "earlyoom-1.6.2-disable-go-module.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
diff --git a/gnu/packages/patches/earlyoom-1.6.2-disable-go-module.patch b/gnu/packages/patches/earlyoom-1.6.2-disable-go-module.patch
new file mode 100644
index 0000000000..f7ef1222ed
--- /dev/null
+++ b/gnu/packages/patches/earlyoom-1.6.2-disable-go-module.patch
@@ -0,0 +1,17 @@ 
+Explicitly disable Go module support for testing with Go >= 1.15
+
+diff --git a/Makefile b/Makefile
+index e072c1b..f301f00 100644
+--- a/Makefile
++++ b/Makefile
+@@ -83,8 +83,8 @@ format: earlyoom
+ 
+ test: earlyoom
+ 	cppcheck -q . || echo "skipping optional cppcheck"
+-	go test -v
++	GO111MODULE=off go test -v
+ 
+ .PHONY: bench
+ bench:
+-	go test -run=NONE -bench=.
++	GO111MODULE=off go test -run=NONE -bench=.