diff mbox series

[bug#49221,09/13] gnu: go-github-com-bmatcuk-doublestar: Remove test incompatible with go-1.16.

Message ID 00966aa0d291e3eeed89103fc456981171b403cf.1624602942.git.iskarian@mgsn.dev
State Accepted
Headers show
Series Add go-1.16 and build with gccgo | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen June 25, 2021, 7:21 a.m. UTC
* gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/golang.scm (go-github-com-bmatcuk-doublestar): Use it.
---
 gnu/local.mk                                      |  1 +
 gnu/packages/golang.scm                           |  5 ++++-
 ...b-com-bmatcuk-doublestar-1.3-remove-test.patch | 15 +++++++++++++++
 3 files changed, 20 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch

Comments

Maxim Cournoyer Aug. 5, 2021, 5:17 p.m. UTC | #1
Hello,

Sarah Morgensen <iskarian@mgsn.dev> writes:

> * gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch:
> New file.
> * gnu/local.mk (dist_patch_DATA): Register it.
> * gnu/packages/golang.scm (go-github-com-bmatcuk-doublestar): Use it.
> ---
>  gnu/local.mk                                      |  1 +
>  gnu/packages/golang.scm                           |  5 ++++-
>  ...b-com-bmatcuk-doublestar-1.3-remove-test.patch | 15 +++++++++++++++
>  3 files changed, 20 insertions(+), 1 deletion(-)
>  create mode 100644 gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 9caae52306..a176772ece 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1172,6 +1172,7 @@ dist_patch_DATA =						\
>    %D%/packages/patches/gobject-introspection-cc.patch		\
>    %D%/packages/patches/gobject-introspection-girepository.patch	\
>    %D%/packages/patches/go-skip-gc-test.patch			\
> +  %D%/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch	\
>    %D%/packages/patches/gpm-glibc-2.26.patch			\
>    %D%/packages/patches/gpodder-disable-updater.patch		\
>    %D%/packages/patches/gpsbabel-fix-i686-test.patch		\
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 9d5fc36710..3170e11925 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -5314,7 +5314,10 @@ template functions.")
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -                "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))))
> +                "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))
> +              (patches
> +               (search-patches
> +                "go-github-com-bmatcuk-doublestar-1.3-remove-test.patch"))))
>      (build-system go-build-system)
>      (arguments
>       `(#:import-path "github.com/bmatcuk/doublestar"))
> diff --git a/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch b/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
> new file mode 100644
> index 0000000000..2c64575914
> --- /dev/null
> +++ b/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
> @@ -0,0 +1,15 @@
> +Remove test which fails with Go >= 1.15 due to API changes.
> +This patch should no longer be necessary with doublestar v4+
> +
> +diff --git a/doublestar_test.go b/doublestar_test.go
> +index b21d20ad4b..f510c3d06b 100644
> +--- a/doublestar_test.go
> ++++ b/doublestar_test.go
> +@@ -80,7 +80,6 @@ var matchTests = []MatchTest{
> + 	{"[", "a", false, ErrBadPattern, true},
> + 	{"[^", "a", false, ErrBadPattern, true},
> + 	{"[^bc", "a", false, ErrBadPattern, true},
> +-	{"a[", "a", false, nil, false},
> + 	{"a[", "ab", false, ErrBadPattern, true},
> + 	{"*x", "xxx", true, nil, true},
> + 	{"[abc]", "b", true, nil, true},

This should be reported upstream, if the test is still not working with
the latest release (v4.0.2).

Thanks,

Maxim
Sarah Morgensen Aug. 5, 2021, 8:23 p.m. UTC | #2
Hi Maxim,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello,
>
> Sarah Morgensen <iskarian@mgsn.dev> writes:
>
>> * gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch:
>> New file.
>> * gnu/local.mk (dist_patch_DATA): Register it.
>> * gnu/packages/golang.scm (go-github-com-bmatcuk-doublestar): Use it.
>> ---
>>  gnu/local.mk                                      |  1 +
>>  gnu/packages/golang.scm                           |  5 ++++-
>>  ...b-com-bmatcuk-doublestar-1.3-remove-test.patch | 15 +++++++++++++++
>>  3 files changed, 20 insertions(+), 1 deletion(-)
>>  create mode 100644 gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
>>
>> diff --git a/gnu/local.mk b/gnu/local.mk
>> index 9caae52306..a176772ece 100644
>> --- a/gnu/local.mk
>> +++ b/gnu/local.mk
>> @@ -1172,6 +1172,7 @@ dist_patch_DATA =						\
>>    %D%/packages/patches/gobject-introspection-cc.patch		\
>>    %D%/packages/patches/gobject-introspection-girepository.patch	\
>>    %D%/packages/patches/go-skip-gc-test.patch			\
>> +  %D%/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch	\
>>    %D%/packages/patches/gpm-glibc-2.26.patch			\
>>    %D%/packages/patches/gpodder-disable-updater.patch		\
>>    %D%/packages/patches/gpsbabel-fix-i686-test.patch		\
>> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
>> index 9d5fc36710..3170e11925 100644
>> --- a/gnu/packages/golang.scm
>> +++ b/gnu/packages/golang.scm
>> @@ -5314,7 +5314,10 @@ template functions.")
>>                (file-name (git-file-name name version))
>>                (sha256
>>                 (base32
>> -                "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))))
>> +                "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))
>> +              (patches
>> +               (search-patches
>> +                "go-github-com-bmatcuk-doublestar-1.3-remove-test.patch"))))
>>      (build-system go-build-system)
>>      (arguments
>>       `(#:import-path "github.com/bmatcuk/doublestar"))
>> diff --git a/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch b/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
>> new file mode 100644
>> index 0000000000..2c64575914
>> --- /dev/null
>> +++ b/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
>> @@ -0,0 +1,15 @@
>> +Remove test which fails with Go >= 1.15 due to API changes.
>> +This patch should no longer be necessary with doublestar v4+
>> +
>> +diff --git a/doublestar_test.go b/doublestar_test.go
>> +index b21d20ad4b..f510c3d06b 100644
>> +--- a/doublestar_test.go
>> ++++ b/doublestar_test.go
>> +@@ -80,7 +80,6 @@ var matchTests = []MatchTest{
>> + 	{"[", "a", false, ErrBadPattern, true},
>> + 	{"[^", "a", false, ErrBadPattern, true},
>> + 	{"[^bc", "a", false, ErrBadPattern, true},
>> +-	{"a[", "a", false, nil, false},
>> + 	{"a[", "ab", false, ErrBadPattern, true},
>> + 	{"*x", "xxx", true, nil, true},
>> + 	{"[abc]", "b", true, nil, true},
>
> This should be reported upstream, if the test is still not working with
> the latest release (v4.0.2).

It is fixed in v2 or v3, but those are backwards-incompatible
upgrades, so I backported this patch.

>
> Thanks,
>
> Maxim

--
Sarah
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 9caae52306..a176772ece 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1172,6 +1172,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/gobject-introspection-cc.patch		\
   %D%/packages/patches/gobject-introspection-girepository.patch	\
   %D%/packages/patches/go-skip-gc-test.patch			\
+  %D%/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch	\
   %D%/packages/patches/gpm-glibc-2.26.patch			\
   %D%/packages/patches/gpodder-disable-updater.patch		\
   %D%/packages/patches/gpsbabel-fix-i686-test.patch		\
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9d5fc36710..3170e11925 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5314,7 +5314,10 @@  template functions.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))))
+                "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))
+              (patches
+               (search-patches
+                "go-github-com-bmatcuk-doublestar-1.3-remove-test.patch"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/bmatcuk/doublestar"))
diff --git a/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch b/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
new file mode 100644
index 0000000000..2c64575914
--- /dev/null
+++ b/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
@@ -0,0 +1,15 @@ 
+Remove test which fails with Go >= 1.15 due to API changes.
+This patch should no longer be necessary with doublestar v4+
+
+diff --git a/doublestar_test.go b/doublestar_test.go
+index b21d20ad4b..f510c3d06b 100644
+--- a/doublestar_test.go
++++ b/doublestar_test.go
+@@ -80,7 +80,6 @@ var matchTests = []MatchTest{
+ 	{"[", "a", false, ErrBadPattern, true},
+ 	{"[^", "a", false, ErrBadPattern, true},
+ 	{"[^bc", "a", false, ErrBadPattern, true},
+-	{"a[", "a", false, nil, false},
+ 	{"a[", "ab", false, ErrBadPattern, true},
+ 	{"*x", "xxx", true, nil, true},
+ 	{"[abc]", "b", true, nil, true},