diff mbox series

[bug#64898,8/9] gnu: Added rust-wee-alloc-0.4.

Message ID d7c6c11b1e88b6e4ad714566c42b7d42eca0ebf6.1690467642.git.w@wmeyer.eu
State New
Headers show
Series rust-emacs-org-link-parser & rust-orgize | expand

Commit Message

Wilko Meyer July 27, 2023, 2:31 p.m. UTC
* added rust-wee-alloc-0.4 to crates-io.scm
---
 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7a7d6b08d8..58691253d0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -71936,6 +71936,30 @@  (define-public rust-webview-sys-0.6
 GUIs as desktop applications.")
     (license license:expat)))
 
+(define-public rust-wee-alloc-0.4
+  (package
+    (name "rust-wee-alloc")
+    (version "0.4.5")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "wee_alloc" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "13hb19nfqwjwcqlfj46sjz4j49wd7sj6hbjasimcn5xvnakbbcyv"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-0.1)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-memory-units" ,rust-memory-units-0.4)
+                       ("rust-spin" ,rust-spin-0.5)
+                       ("rust-winapi" ,rust-winapi-0.3))))
+    (home-page "https://github.com/rustwasm/wee_alloc")
+    (synopsis "wee_alloc: The Wasm-Enabled, Elfin Allocator")
+    (description "wee_alloc: The Wasm-Enabled, Elfin Allocator")
+    (license license:mpl2.0)))
+
 (define-public rust-weezl-0.1
   (package
     (name "rust-weezl")