diff mbox series

[bug#64898,1/9] gnu: Added rust-indextree-4.

Message ID 21caffb7a057771da7e7e37505f1b573db3e29bf.1690467642.git.w@wmeyer.eu
State New
Headers show
Series rust-emacs-org-link-parser & rust-orgize | expand

Commit Message

Wilko Meyer July 27, 2023, 2:31 p.m. UTC
* added rust-indextree-4 to crates-io.scm
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index af77a40257..91f94af642 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Paul Alesius <paul@unnservice.com>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29160,6 +29161,30 @@  (define-public rust-indenter-0.3
 that efficiently appends and removes common indentation after every newline.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-indextree-4
+  (package
+    (name "rust-indextree")
+    (version "4.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "indextree" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1dnysxws5kpw8c3yvnhq3r9p2kfqqrgcw29x7hrg2gn6wp812164"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-rayon" ,rust-rayon-1)
+                       ("rust-serde" ,rust-serde-1))))
+    (home-page "https://github.com/saschagrunert/indextree")
+    (synopsis
+     "Arena based tree structure by using indices instead of reference counted pointers")
+    (description
+     "Arena based tree structure by using indices instead of reference counted
+pointers")
+    (license license:expat)))
+
 (define-public rust-indexmap-1
   (package
     (name "rust-indexmap")