diff mbox series

[bug#69353,1/2] gnu: Add greatest.

Message ID d5e381e340b969f538466af559770af1c18843b3.1708773367.git.liliana.prikler@gmail.com
State New
Headers show
Series The greatest theft since the invention of software | expand

Commit Message

Liliana Marie Prikler Feb. 24, 2024, 11:01 a.m. UTC
* gnu/packages/check.scm (greatest): New variable.
---
 gnu/packages/check.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5237f93a93..b0d2ff199b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -966,6 +966,29 @@  (define-public googlebenchmark
 similar to unit tests.")
     (license license:asl2.0)))
 
+(define-public greatest
+  (package
+   (name "greatest")
+   (version "1.5.0")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/silentbicycle/greatest")
+                  (commit (string-append "v" version))))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "11rajkb5m7mlzi3i3v0i27k6rrjw3x8a7bl6fkc29igzpwfbxndy"))))
+   (build-system copy-build-system)
+   (arguments (list #:install-plan
+                    #~'(("greatest.h" "include/"))))
+   (home-page "https://github.com/silentbicycle/greatest")
+   (synopsis "Single-header test system")
+   (description "Greatest is a single-header test system for C, including
+macros for defining tests, grouping them into suites, and providing a test
+runner.  It is quite unopinionated with most of its features being optional.")
+   (license license:isc)))
+
 (define-public cpputest
   (package
     (name "cpputest")