diff mbox series

[bug#69353,2/2] gnu: Add theft.

Message ID 7ec94ff5aafea4ab31293b2925bdf75a0217a38a.1708773367.git.liliana.prikler@gmail.com
State New
Headers show
Series The greatest theft since the invention of software | expand

Commit Message

Liliana Marie Prikler Feb. 24, 2024, 11:01 a.m. UTC
* gnu/packages/check.scm (theft): New variable.
---
 gnu/packages/check.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b0d2ff199b..c822f23b8b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3127,6 +3127,36 @@  (define-public python-pyhamcrest
 allowing you to declaratively define \"match\" rules.")
     (license license:bsd-3)))
 
+(define-public theft
+  (package
+   (name "theft")
+   (version "0.4.5")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/silentbicycle/theft")
+                  (commit (string-append "v" version))))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "1n2mkawfl2bpd4pwy3mdzxwlqjjvb5bdrr2x2gldlyqdwbk7qjhd"))
+            (snippet #~(begin
+                         (delete-file "vendor/greatest.h")))))
+   (build-system gnu-build-system)
+   (arguments (list #:make-flags #~(list "VENDOR="
+                                         (string-append "CC=" #$(cc-for-target))
+                                         (string-append "PREFIX=" #$output))
+                    #:test-target "test"
+                    #:phases
+                    #~(modify-phases %standard-phases
+                        (delete 'bootstrap)
+                        (delete 'configure))))
+   (native-inputs (list greatest))
+   (home-page "https://github.com/silentbicycle/theft")
+   (synopsis "Property-based testing for C")
+   (description "Theft is a library for property-based testing.")
+   (license license:isc)))
+
 (define-public unittest-cpp
   (package
     (name "unittest-cpp")