diff mbox series

[bug#69363,85/87] gnu: rust-syntect: Update to 5.2.0.

Message ID d1a0cb06c2c86c87ccf3bee38385db8f45d14682.1708807224.git.voroskoi@gmail.com
State New
Headers show
Series [bug#69363,01/87] gnu: Add rust-bwrap-1.3.0. | expand

Commit Message

VÖRÖSKŐI András Feb. 24, 2024, 8:40 p.m. UTC
* gnu/packages/crates-io.scm (rust-syntect-5): Update to 5.2.0.

Change-Id: I18fbcae0e17c5cee8d1a360511ce9832b821ae83
---
 gnu/packages/crates-io.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index aa501ffaad..12e5fa26eb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -68266,14 +68266,14 @@  (define-public rust-synstructure-test-traits-0.1
 (define-public rust-syntect-5
   (package
     (name "rust-syntect")
-    (version "5.1.0")
+    (version "5.2.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "syntect" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "14cg314vzabi45cdbqgcpav0dlx3d18blp24n3z8pl7q7cq4naz0"))))
+        (base32 "1ca68wxr8qs99ivqc266492sz8qwfngswizr7hrh8mlrcfiwykc7"))))
     (build-system cargo-build-system)
     (arguments
      `(#:tests? #f                      ;missing files
@@ -68286,18 +68286,23 @@  (define-public rust-syntect-5
         ("rust-once-cell" ,rust-once-cell-1)
         ("rust-onig" ,rust-onig-6)
         ("rust-plist" ,rust-plist-1)
-        ("rust-regex-syntax" ,rust-regex-syntax-0.7)
+        ("rust-regex-syntax" ,rust-regex-syntax-0.8)
         ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
         ("rust-serde-json" ,rust-serde-json-1)
         ("rust-thiserror" ,rust-thiserror-1)
         ("rust-walkdir" ,rust-walkdir-2)
         ("rust-yaml-rust" ,rust-yaml-rust-0.4))
        #:cargo-development-inputs
        (("rust-criterion" ,rust-criterion-0.3)
+        ("rust-expect-test" ,rust-expect-test-1)
         ("rust-getopts" ,rust-getopts-0.2)
         ("rust-pretty-assertions" ,rust-pretty-assertions-0.6)
+        ("rust-public-api" ,rust-public-api-0.33)
         ("rust-rayon" ,rust-rayon-1)
-        ("rust-regex" ,rust-regex-1))))
+        ("rust-regex" ,rust-regex-1)
+        ("rust-rustdoc-json" ,rust-rustdoc-json-0.8)
+        ("rust-rustup-toolchain" ,rust-rustup-toolchain-0.1))))
     (home-page "https://github.com/trishume/syntect")
     (synopsis "Library for syntax highlighting and code intelligence")
     (description