diff mbox series

[bug#73522,games-team,03/14] gnu: Add retroarch-joypad-autoconfig.

Message ID d11a5ee5c6b4b296f9598647e1225b55f0b2e163.1728192708.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Package and use RetroArch assets, plus other improvements. | expand

Commit Message

Maxim Cournoyer Oct. 6, 2024, 5:31 a.m. UTC
* gnu/packages/emulators.scm (retroarch-joypad-autoconfig): New variable.

Change-Id: I56fe94f78b661c082a6e59fd59980462a0884a03
---

 gnu/packages/emulators.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 56ef97567e..a1e5a1f0c9 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1549,6 +1549,34 @@  (define-public retroarch-core-info
 @url{https://github.com/libretro/libretro-super, libretro-super} repository.")
       (license license:expat))))
 
+(define-public retroarch-joypad-autoconfig
+  (package
+    (name "retroarch-joypad-autoconfig")
+    (version "1.19.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/libretro/retroarch-joypad-autoconfig")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1gg4nc2wjqz72z40diqbanfkfalvb9hhb8scwn51v2w704rm634b"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests? #f                  ;no meaningful test suite
+           #:make-flags #~(list (string-append "PREFIX=" #$output))
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure)))) ;no configure script
+    (home-page "https://github.com/libretro/retroarch-joypad-autoconfig")
+    (synopsis "RetroArch joypad autoconfig files")
+    (description "This package provides joypad autoconfig files for RetroArch,
+the reference frontend for the libretro API.  The autoconfig files are used to
+recognize input devices and automatically setup default mappings between the
+physical device and the RetroPad virtual controller.")
+    (license license:expat)))
+
 (define-public retroarch
   (package
     (name "retroarch")