diff mbox series

[bug#73522,games-team,05/14] gnu: retroarch: Add missing inputs, upgrade Qt to version 6.

Message ID cf7ac8026c014fe27b33325f57da7d6d0138d00a.1728192708.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Package and use RetroArch assets, plus other improvements. | expand

Commit Message

Maxim Cournoyer Oct. 6, 2024, 5:32 a.m. UTC
* gnu/packages/emulators.scm (retroarch) [inputs]: Add fontconfig and
v4l-utils.  Replace qtbase-5 with qtbase.

Change-Id: Ie82581b1f2cd8ce23f4ea04e5e09e3d6401d9464
---

 gnu/packages/emulators.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Maxim Cournoyer Oct. 6, 2024, 7:22 a.m. UTC | #1
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

>             python
> -           qtbase-5
> +           qtbase
>             sdl2

I'll revert this bit, I just noticed the Qt menu was no more. It still
expects Qt 5:

--8<---------------cut here---------------start------------->8---
Checking presence of package Qt5Core >= 5.2 ... no
Checking presence of package Qt5Gui >= 5.2 ... no
Checking presence of package Qt5Widgets >= 5.2 ... no
Checking presence of package Qt5Concurrent >= 5.2 ... no
Checking presence of package Qt5Network >= 5.2 ... no
Notice: Qt support disabled, required libraries were not found.
--8<---------------cut here---------------end--------------->8---
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 92156f10df..afe11caf7f 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1632,6 +1632,7 @@  (define-public retroarch
            eudev
            ffmpeg
            flac
+           fontconfig
            freetype
            glslang
            libxinerama
@@ -1645,10 +1646,11 @@  (define-public retroarch
            openssl
            pulseaudio
            python
-           qtbase-5
+           qtbase
            sdl2
            spirv-headers
            spirv-tools
+           v4l-utils
            vulkan-loader
            wayland
            zlib))