diff mbox series

[bug#68276,3/4] gnu: iwd: Use gexps.

Message ID cfb9dbcb54af4a71b13b4d395c4a0317ed5feca4.1704519990.git.hako@ultrarare.space
State New
Headers show
Series gnu: iwd: Update to 2.12. | expand

Commit Message

Hilton Chain Jan. 6, 2024, 6:04 a.m. UTC
* gnu/packages/networking.scm (iwd): Use gexps.

Change-Id: Ie4a6394c9c7977291f56990eb1a535ba673d04ee
---
 gnu/packages/networking.scm | 62 ++++++++++++++++++-------------------
 1 file changed, 31 insertions(+), 31 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index fda6775d71..20674de76d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3959,37 +3959,37 @@  (define-public iwd
            python-docutils
            openssl))
     (arguments
-     `(#:configure-flags
-       ,#~(list "--disable-systemd-service"
-                "--enable-external-ell"
-                "--enable-hwsim"
-                "--enable-tools"
-                "--enable-wired"
-                "--localstatedir=/var"
-                (string-append "--with-dbus-datadir=" #$output "/share/")
-                (string-append "--with-dbus-busdir="
-                               #$output "/share/dbus-1/system-services"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'copy-ell-header-files
-           ;; Copy into the source tree two of ell's private header files that
-           ;; it shares with iwd, as is required to build with the
-           ;; "--enable-external-ell" configure option.
-           ;; See the definition of "ell_shared" in iwd's Makefile.am.
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((ell-header-dir (search-input-directory inputs "/ell"))
-                   (target-dir "ell"))
-               (mkdir target-dir)
-               (for-each
-                (lambda (file-name)
-                  (copy-file (string-append ell-header-dir "/" file-name)
-                             (string-append target-dir "/" file-name)))
-                '("asn1-private.h" "useful.h")))))
-         (add-after 'configure 'patch-Makefile
-           (lambda _
-             (substitute* "Makefile"
-               ;; Don't try to 'mkdir /var'.
-               (("\\$\\(MKDIR_P\\) -m 700") "true")))))))
+     (list #:configure-flags
+           #~(list "--disable-systemd-service"
+                   "--enable-external-ell"
+                   "--enable-hwsim"
+                   "--enable-tools"
+                   "--enable-wired"
+                   "--localstatedir=/var"
+                   (string-append "--with-dbus-datadir=" #$output "/share/")
+                   (string-append "--with-dbus-busdir="
+                                  #$output "/share/dbus-1/system-services"))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'copy-ell-header-files
+                 ;; Copy into the source tree two of ell's private header files
+                 ;; that it shares with iwd, as is required to build with the
+                 ;; "--enable-external-ell" configure option.  See the
+                 ;; definition of "ell_shared" in iwd's Makefile.am.
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (let ((ell-header-dir (search-input-directory inputs "/ell"))
+                         (target-dir "ell"))
+                     (mkdir target-dir)
+                     (for-each
+                      (lambda (file-name)
+                        (copy-file (string-append ell-header-dir "/" file-name)
+                                   (string-append target-dir "/" file-name)))
+                      '("asn1-private.h" "useful.h")))))
+               (add-after 'configure 'patch-Makefile
+                 (lambda _
+                   (substitute* "Makefile"
+                     ;; Don't try to 'mkdir /var'.
+                     (("\\$\\(MKDIR_P\\) -m 700") "true")))))))
     (home-page "https://iwd.wiki.kernel.org/")
     (synopsis "iNet Wireless Daemon")
     (description "iwd is a wireless daemon for Linux that aims to replace WPA