diff mbox series

[bug#68276,4/4] gnu: iwd: Patch resolvconf path.

Message ID 5f077d8952d96050ec3ae8dbbb52786766bbfa90.1704519990.git.hako@ultrarare.space
State New
Headers show
Series gnu: iwd: Update to 2.12. | expand

Commit Message

Hilton Chain Jan. 6, 2024, 6:04 a.m. UTC
* gnu/packages/networking.scm (iwd)[inputs]: Add openresolv.
[arguments]<#:phases>: Add 'patch-resolvconf-path.

Change-Id: Ica59a76dd6318e06979314e4b49c5371f4c98e4d
---
 gnu/packages/networking.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 20674de76d..a6798bb166 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -113,6 +113,7 @@  (define-module (gnu packages networking)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages dejagnu)
+  #:use-module (gnu packages dns)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages flex)
@@ -3949,7 +3950,7 @@  (define-public iwd
                 "199pcs20054xhp5c0dnxf9ny5cf5cynkqpx68dpn46nq8ly76n2y"))))
     (build-system gnu-build-system)
     (inputs
-     (list dbus ell (package-source ell) readline))
+     (list dbus ell (package-source ell) openresolv readline))
     (native-inputs
      (list autoconf
            automake
@@ -3985,6 +3986,13 @@  (define-public iwd
                         (copy-file (string-append ell-header-dir "/" file-name)
                                    (string-append target-dir "/" file-name)))
                       '("asn1-private.h" "useful.h")))))
+               (add-after 'unpack 'patch-resolvconf-path
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (substitute* "src/resolve.c"
+                     (("getenv\\(\"PATH\"\\)")
+                      (format #f "\"~a\""
+                              (dirname (search-input-file
+                                        inputs "sbin/resolvconf")))))))
                (add-after 'configure 'patch-Makefile
                  (lambda _
                    (substitute* "Makefile"