diff mbox series

[bug#68641,17/19] gnu: libpasastro: Use G-Expressions.

Message ID cf8f755165383881d7a2b423568cb097670d0d40.1705854493.git.sharlatanus@gmail.com
State New
Headers show
Series gnu: Astronomy 2024/01 updates. | expand

Commit Message

Sharlatan Hellseher Jan. 21, 2024, 4:53 p.m. UTC
* gnu/packages/astronomy.scm (libpasastro):
[supported-systems]: Add it.
[arguments]: Rewrite using G-expressions.
[description]; Remove trailing \n.

Change-Id: Ic0e79394be1110566f5481963fdd167985c1a770
---
 gnu/packages/astronomy.scm | 41 ++++++++++++++++++++++----------------
 1 file changed, 24 insertions(+), 17 deletions(-)

Comments

Efraim Flashner Jan. 24, 2024, 11:58 a.m. UTC | #1
$ file /gnu/store/qb3jlcb068iv6fz1sqypr12zrcxgi6aq-libpasastro-1.4.2/lib/libpasgetdss.so.1.1
/gnu/store/qb3jlcb068iv6fz1sqypr12zrcxgi6aq-libpasastro-1.4.2/lib/libpasgetdss.so.1.1: ELF 64-bit LSB shared object, UCB RISC-V, RVC, double-float ABI, version 1 (SYSV), dynamically linked, stripped

This package compiles just fine for riscv64 so there's no reason to
limit it to only certain architectures.

On Sun, Jan 21, 2024 at 04:53:57PM +0000, Sharlatan Hellseher wrote:
> * gnu/packages/astronomy.scm (libpasastro):
> [supported-systems]: Add it.
> [arguments]: Rewrite using G-expressions.
> [description]; Remove trailing \n.
> 
> Change-Id: Ic0e79394be1110566f5481963fdd167985c1a770
> ---
>  gnu/packages/astronomy.scm | 41 ++++++++++++++++++++++----------------
>  1 file changed, 24 insertions(+), 17 deletions(-)
> 
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index dd7473df49..c049e6e67f 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -3179,23 +3179,30 @@ (define-public libpasastro
>         (sha256
>          (base32 "1na3gyb3nzb5gdgccs1653j2gnz6w3v1mqzhyhkx3yqw8bs3q5x0"))))
>      (build-system gnu-build-system)
> +    (supported-systems '("i686-linux" "x86_64-linux"
> +                         "armhf-linux" "aarch64-linux"))
>      (arguments
> -     `(#:tests? #f
> -       #:make-flags
> -       (list
> -        ,(match (or (%current-target-system) (%current-system))
> -           ((or "aarch64-linux" "armhf-linux" "i686-linux" "x86_64-linux")
> -            "OS_TARGET=linux")
> -           (_ #f))
> -        ,(match (or (%current-target-system) (%current-system))
> -           ("i686-linux" "CPU_TARGET=i386")
> -           ("x86_64-linux" "CPU_TARGET=x86_64")
> -           ((or "armhf-linux" "aarch64-linux") "CPU_TARGET=armv7l")
> -           (_ #f))
> -        (string-append "PREFIX=" (assoc-ref %outputs "out")))
> -       #:phases
> -       (modify-phases %standard-phases
> -         (delete 'configure))))
> +     (list
> +      #:tests? #f ; no tests provided
> +      #:make-flags
> +      #~(list
> +         ;; Keep OS detection for the case when Hurd would be suitable to try.
> +         #$@(if (target-linux?) '("OS_TARGET=linux") '())
> +         ;; Enable buildtime CPU detection where supported,
> +         ;; and set a suitable CPU target variable.

(%current-target-system) returns i686-linux-gnu for the first one, so
it'd probably be better to use cond and (target-x86-32?) for the first
one.

I'm not actually convinced you need any of the flags for OS_TARGET or
CPU_TARGET (except perhaps for cross-compiling), does it make a
difference between compiled with or without?

> +         #$@(match (or (%current-target-system)
> +                       (%current-system))
> +              ("i686-linux"
> +               '("CPU_TARGET=i386"))
> +              ("x86_64-linux"
> +               '("CPU_TARGET=x86_64"))
> +              ((or "armhf-linux" "aarch64-linux")
> +               '("CPU_TARGET=armv7l"))
> +              (_ '()))
> +         (string-append "PREFIX=" #$output))
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (delete 'configure))))
>      (home-page "https://github.com/pchev/libpasastro")
>      (synopsis "Interface to astronomy library for use from Pascal program")
>      (description
> @@ -3207,7 +3214,7 @@ (define-public libpasastro
>  @item @code{libpasplan404.so}: Interface with Plan404 to compute planets position.
>  @item @code{libpaswcs.so}: Interface with libwcs to work with FITS WCS.
>  @item @code{libpasspice.so}: To work with NAIF/SPICE kernel.
> -@end itemize\n")
> +@end itemize")
>        (license license:gpl2+)))
>  
>  (define-public libxisf
> -- 
> 2.41.0
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index dd7473df49..c049e6e67f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3179,23 +3179,30 @@  (define-public libpasastro
        (sha256
         (base32 "1na3gyb3nzb5gdgccs1653j2gnz6w3v1mqzhyhkx3yqw8bs3q5x0"))))
     (build-system gnu-build-system)
+    (supported-systems '("i686-linux" "x86_64-linux"
+                         "armhf-linux" "aarch64-linux"))
     (arguments
-     `(#:tests? #f
-       #:make-flags
-       (list
-        ,(match (or (%current-target-system) (%current-system))
-           ((or "aarch64-linux" "armhf-linux" "i686-linux" "x86_64-linux")
-            "OS_TARGET=linux")
-           (_ #f))
-        ,(match (or (%current-target-system) (%current-system))
-           ("i686-linux" "CPU_TARGET=i386")
-           ("x86_64-linux" "CPU_TARGET=x86_64")
-           ((or "armhf-linux" "aarch64-linux") "CPU_TARGET=armv7l")
-           (_ #f))
-        (string-append "PREFIX=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+     (list
+      #:tests? #f ; no tests provided
+      #:make-flags
+      #~(list
+         ;; Keep OS detection for the case when Hurd would be suitable to try.
+         #$@(if (target-linux?) '("OS_TARGET=linux") '())
+         ;; Enable buildtime CPU detection where supported,
+         ;; and set a suitable CPU target variable.
+         #$@(match (or (%current-target-system)
+                       (%current-system))
+              ("i686-linux"
+               '("CPU_TARGET=i386"))
+              ("x86_64-linux"
+               '("CPU_TARGET=x86_64"))
+              ((or "armhf-linux" "aarch64-linux")
+               '("CPU_TARGET=armv7l"))
+              (_ '()))
+         (string-append "PREFIX=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure))))
     (home-page "https://github.com/pchev/libpasastro")
     (synopsis "Interface to astronomy library for use from Pascal program")
     (description
@@ -3207,7 +3214,7 @@  (define-public libpasastro
 @item @code{libpasplan404.so}: Interface with Plan404 to compute planets position.
 @item @code{libpaswcs.so}: Interface with libwcs to work with FITS WCS.
 @item @code{libpasspice.so}: To work with NAIF/SPICE kernel.
-@end itemize\n")
+@end itemize")
       (license license:gpl2+)))
 
 (define-public libxisf