diff mbox series

[bug#70400,6/7] gnu: python-rope: Update to 1.13.0.

Message ID cda478d3dcc7af02cf45bca45b6211d124b50f2a.1713203110.git.jpieper@mailbox.org
State New
Headers show
Series [bug#70400,1/7] gnu: Add python-docstring-to-markdown. | expand

Commit Message

Jonathan Pieper April 15, 2024, 5:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-rope): Update to 1.13.0.
  [arguments]{disable-broken-tests}: Disable test_hint_or.
  [propagated-inputs]: Add python-pytoolconfig.

Change-Id: I0717c76631ca744a0f601734f707f45fa05b62c2
---
 gnu/packages/python-xyz.scm | 34 ++++++++++++++++++----------------
 1 file changed, 18 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 33410c0a06..cead2adb44 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20057,31 +20057,33 @@  (define-public python-cysignals
 (define-public python-rope
   (package
     (name "python-rope")
-    (version "1.1.1")
+    (version "1.13.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "rope" version))
        (sha256
-        (base32
-         "0bkzwkllxxdxd3w70xiy137lqvnlmmaplsc2ya3s23ss4kq8y10k"))))
+        (base32 "1078mkzivz45my8x2y5gxisr0vba630xj7yxx7anr068xhnpshsi"))))
     (build-system python-build-system)
     (arguments
-     (list #:phases
-           `(modify-phases %standard-phases
-              (add-after 'unpack 'disable-broken-test
-                (lambda _
-                  (substitute* "ropetest/contrib/autoimporttest.py"
-                    (("def test_search_module")
-                     "def __notest_search_module")
-                    (("def test_search_submodule")
-                     "def __notest_search_submodule")))))))
-    (native-inputs
-     (list python-pytest-timeout
-           python-pytest))
+     (list
+      #:phases `(modify-phases %standard-phases
+                  (add-after 'unpack 'disable-broken-test
+                    (lambda _
+                      (substitute* "ropetest/contrib/autoimporttest.py"
+                        (("def test_search_module")
+                         "def __notest_search_module")
+                        (("def test_search_submodule")
+                         "def __notest_search_submodule"))
+                      (substitute* "ropetest/type_hinting_test.py"
+                        (("def test_hint_or")
+                         "def __notest_hint_or")))))))
+    (native-inputs (list python-pytest-timeout python-pytest))
+    (propagated-inputs (list python-pytoolconfig))
     (home-page "https://github.com/python-rope/rope")
     (synopsis "Refactoring library for Python")
-    (description "Rope is a refactoring library for Python.  It facilitates
+    (description
+     "Rope is a refactoring library for Python.  It facilitates
 the renaming, moving and extracting of attributes, functions, modules, fields
 and parameters in Python source code.  These refactorings can also be applied
 to occurrences in strings and comments.")