diff mbox series

[bug#70400,1/7] gnu: Add python-docstring-to-markdown.

Message ID 7d0ec10d21258d9f858f9c9fe2cde132d4a06106.1713203110.git.jpieper@mailbox.org
State New
Headers show
Series [bug#70400,1/7] gnu: Add python-docstring-to-markdown. | expand

Commit Message

Jonathan Pieper April 15, 2024, 5:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-docstring-to-markdown): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: 6b3c90f638292f9604a221ac6dbf22234f6e4c4b
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92566abfed..9521119a84 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1376,6 +1376,25 @@  (define-public python-mkdocs-markdownextradata-plugin
 variables into the markdown template")
     (license license:expat)))
 
+(define-public python-docstring-to-markdown
+  (package
+    (name "python-docstring-to-markdown")
+    (version "0.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "docstring-to-markdown" version))
+       (sha256
+        (base32 "0gdpabnyl1kyy0cjrnph6xl4fyhgim50a1amsaqq3hahki6i2ip1"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/python-lsp/docstring-to-markdown")
+    (synopsis "On the fly conversion of Python docstrings to markdown")
+    (description
+     "This module can convert Python docstrings to Markdown.
+It can recognise reStructuredText inside docstrings and convert multiple of its
+features to Markdown. It also includes initial support for Google-formatted docstrings.")
+    (license license:lgpl2.1+)))
+
 (define-public python-mysql-connector-python
   (package
     (name "python-mysql-connector-python")