diff mbox series

[bug#57524] gnu: Add python-plotille.

Message ID cd4af15b37552311318742c43a8fd17188f60d02.1662038821.git.peter@polidoro.io
State Accepted
Headers show
Series [bug#57524] gnu: Add python-plotille. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro Sept. 1, 2022, 1:28 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-plotille): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Thompson, David Sept. 1, 2022, 3:37 p.m. UTC | #1
Hi Peter,

Thanks for the patch!

On Thu, Sep 1, 2022 at 9:46 AM <peter@polidoro.io> wrote:
>
> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/python-xyz.scm (python-plotille): New variable.
> ---
>  gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 9b3d5edb93..600d7478f7 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -743,6 +743,26 @@ (define-public python-pymdown-extensions
>  Markdown.  All extensions are found under the module namespace of pymdownx.")
>      (license license:expat)))
>
> +(define-public python-plotille
> +  (package
> +    (name "python-plotille")
> +    (version "4.0.2")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "plotille" version))
> +              (sha256
> +               (base32
> +                "0fvsk6glxfphhqy405h05rj3v95jd1byl5hv2fyd5l31wln23shj"))))
> +    (build-system python-build-system)
> +    (native-inputs (list python-six))
> +    (home-page "https://github.com/tammoippen/plotille")
> +    (synopsis "Plot in the terminal using braille dots")
> +    (description
> +     "This package provides a figure class and graphing functions
> +to create plots, scatter plots, histograms and heatmaps in the terminal using
> +braille dots.")

I adjusted the description slightly so it says "Plotille provides..."
instead of "This package provides..."

> +    (license license:expat)))
> +
>  (define-public python-mdx-gh-links
>    (package
>      (name "python-mdx-gh-links")
> --
> 2.37.2

Pushed to master as commit 13f53335ef62c4c68789e9255794a274b3beb6e4.

- Dave
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b3d5edb93..600d7478f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -743,6 +743,26 @@  (define-public python-pymdown-extensions
 Markdown.  All extensions are found under the module namespace of pymdownx.")
     (license license:expat)))
 
+(define-public python-plotille
+  (package
+    (name "python-plotille")
+    (version "4.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "plotille" version))
+              (sha256
+               (base32
+                "0fvsk6glxfphhqy405h05rj3v95jd1byl5hv2fyd5l31wln23shj"))))
+    (build-system python-build-system)
+    (native-inputs (list python-six))
+    (home-page "https://github.com/tammoippen/plotille")
+    (synopsis "Plot in the terminal using braille dots")
+    (description
+     "This package provides a figure class and graphing functions
+to create plots, scatter plots, histograms and heatmaps in the terminal using
+braille dots.")
+    (license license:expat)))
+
 (define-public python-mdx-gh-links
   (package
     (name "python-mdx-gh-links")