diff mbox series

[bug#66929,05/10] gnu: Add python-perfplot.

Message ID cd42c3d1a2cbc860e4c6e2fcfab12f542752cdab.1699109092.git.felgru@posteo.net
State New
Headers show
Series Add python-quadpy and dependencies. | expand

Commit Message

Felix Gruber Nov. 4, 2023, 3:02 p.m. UTC
* gnu/packages/python-xyz.scm (python-perfplot): New variable.

Change-Id: I04266dfd7081bd3f917a48b2667137b829680498
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f2e55e2788..b69cd19f45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8346,6 +8346,30 @@  (define-public python-cplot
 complex-valued functions.")
     (license license:gpl3)))
 
+(define-public python-perfplot
+  (package
+    (name "python-perfplot")
+    (version "0.10.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "perfplot" version))
+              (sha256
+               (base32
+                "0hbyv17f9ra6l6albcrqx4rylmfv2m6z4qsnhb4bar256dralvfp"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-matplotlib
+                             python-matplotx
+                             python-numpy
+                             python-rich))
+    (native-inputs (list python-flit-core
+                         python-pytest))
+    (home-page "https://github.com/nschloe/perfplot")
+    (synopsis "Performance plots for Python code snippets")
+    (description "@code{perfplot} extends Python's timeit by testing
+snippets with input parameters (e.g., the size of an array) and plotting
+the results.")
+    (license license:gpl3)))
+
 (define-public python-pysnptools
   (package
     (name "python-pysnptools")