diff mbox series

[bug#66929,04/10] gnu: Add python-cplot.

Message ID 7008c188049dd0c03e50946e866c172b0d427d3b.1699109092.git.felgru@posteo.net
State New
Headers show
Series Add python-quadpy and dependencies. | expand

Commit Message

Felix Gruber Nov. 4, 2023, 3:02 p.m. UTC
* gnu/packages/python-xyz.scm (python-cplot): New variable.

Change-Id: I8e634799954b120e00d900ae26b16af1717d4474
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54e1086af8..f2e55e2788 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8321,6 +8321,31 @@  (define-public python-matplotx
 clean plots with a minimalistic style.")
     (license license:expat)))
 
+(define-public python-cplot
+  (package
+    (name "python-cplot")
+    (version "0.9.3")
+    (source
+     (origin
+       (method git-fetch)   ;for tests
+       (uri (git-reference
+             (url "https://github.com/nschloe/cplot")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zk7hpq358sbympmkms7w2wjs7nw8mdfvkvdasblg2nhqayv42qz"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-matplotlib
+                             python-matplotx
+                             python-npx
+                             python-numpy))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/nschloe/cplot")
+    (synopsis "Plot complex-valued functions")
+    (description "@code{cplot} is a Python library for plotting
+complex-valued functions.")
+    (license license:gpl3)))
+
 (define-public python-pysnptools
   (package
     (name "python-pysnptools")