diff mbox series

[bug#70955,5/6] gnu: Add go-github-com-pion-dtls-v2.

Message ID caf5c6162a9046b23dc4f5a6a360d8f1bebe1f37.1715753200.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-pion-stun-v2 and go-github-com-pion-mdns. | expand

Commit Message

Artyom V. Poptsov May 15, 2024, 6:17 a.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-pion-dtls-v2): New variable.

Change-Id: Ia3e77cda47fcb5a17a6cb7a82cd43f2beb8de1e9
---
 gnu/packages/golang-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ca9e88547e..b91a28c436 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3084,6 +3084,36 @@  (define-public go-github-com-pion-mdns
 WebRTC.")
     (license license:expat)))
 
+(define-public go-github-com-pion-dtls-v2
+  (package
+    (name "go-github-com-pion-dtls")
+    (version "2.2.11")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pion/dtls/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "10nn9349f7snqkzncda5m013fgnzicrcxi6pb6ghc0vb6rhqkf30"))))
+    (build-system go-build-system)
+    (native-inputs (list go-github-com-stretchr-testify))
+    (propagated-inputs (list go-github-com-pion-logging
+                             go-github-com-pion-transport-v3
+                             go-github-com-pion-transport-v2
+                             go-golang-org-x-crypto go-golang-org-x-net))
+    (arguments
+     (list
+      #:go go-1.21
+      #:import-path "github.com/pion/dtls/v2"))
+    (home-page "https://github.com/pion/dtls/")
+    (synopsis "DTLS 1.2 Server/Client implementation for Go")
+    (description
+     "Native @url{https://datatracker.ietf.org/doc/html/rfc6347, DTLS 1.2}
+implementation in the Go programming language.")
+    (license license:expat)))
+
 (define-public go-github-com-prometheus-client-model
   (package
     (name "go-github-com-prometheus-client-model")