diff mbox series

[bug#55831] gnu: Add python-starlette.

Message ID c5d49b019d635d3bb4eecb5a02478b98dbda8c90.1654612301.git.peter@polidoro.io
State New
Headers show
Series [bug#55831] gnu: Add python-starlette. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro June 7, 2022, 2:35 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-starlette): New variable.
---
 gnu/packages/python-web.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06a0d2593b..874ef73093 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1200,6 +1200,24 @@  (define-public python-h2
 Python HTTP implementation.")
     (license license:expat)))
 
+(define-public python-starlette
+  (package
+    (name "python-starlette")
+    (version "0.20.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "starlette" version))
+              (sha256
+               (base32
+                "1si8plb5lgwkcaqzccrrisiksdrxldq94kij73i0mizn7l42g0nx"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-anyio python-typing-extensions))
+    (home-page "https://github.com/encode/starlette")
+    (synopsis "Lightweight ASGI framework for building async web services in Python")
+    (description "This package is a lightweight Asynchronous Server Gateway Interface for
+building async web services in Python.")
+    (license license:bsd-3)))
+
 (define-public python-sockjs-tornado
   (package
     (name "python-sockjs-tornado")