diff mbox series

[bug#68500,v2,2/2] gnu: ausweisapp: Update to 2.1.0.

Message ID c3d7d864219f9cee667c2ebeff9d3363e7e23816.1709575388.git.sarg@sarg.org.ru
State New
Headers show
Series [bug#68500,v2,1/2] gnu: qtscxml: Update to 6.5.2. | expand

Commit Message

Sergey Trofimov March 4, 2024, 6:03 p.m. UTC
* gnu/packages/security-token.scm (ausweisapp): Update to 2.1.0.
(ausweisapp2): Rename to ausweisapp.
---
 gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
 1 file changed, 22 insertions(+), 23 deletions(-)

Comments

Maxim Cournoyer March 10, 2024, 1:28 a.m. UTC | #1
Hi Sergey,

Sergey Trofimov <sarg@sarg.org.ru> writes:

> * gnu/packages/security-token.scm (ausweisapp): Update to 2.1.0.
> (ausweisapp2): Rename to ausweisapp.

The changelog commit message should mention the change to inputs and
arguments, e.g.:

[native-inputs]: Replace qttools-5 with qttools.
...

> ---
>  gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
>  1 file changed, 22 insertions(+), 23 deletions(-)
>
> diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
> index a1fc058db8..3e46e318c3 100644
> --- a/gnu/packages/security-token.scm
> +++ b/gnu/packages/security-token.scm
> @@ -950,43 +950,42 @@ (define-public nitrocli
>  devices.")
>      (license license:gpl3+)))
>  
> -(define-public ausweisapp2
> +(define-public ausweisapp
>    (package
> -    (name "ausweisapp2")
> -    (version "1.22.2")
> +    (name "ausweisapp")
> +    (version "2.1.0")
>      (source (origin
>                (method url-fetch)
> -              (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
> -                                  "/download/" version "/AusweisApp2-" version ".tar.gz"))
> +              (uri (string-append "https://github.com/Governikus/AusweisApp/releases"
> +                                  "/download/" version "/AusweisApp-" version ".tar.gz"))
>                (sha256
>                 (base32
> -                "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
> +                "1jzxfybjrc3byw42bqjvn1nsn7vbgcl8y94sywjy6vaj3a58hy36"))))
>  
> -    (build-system cmake-build-system)
> +    (build-system qt-build-system)
>      (native-inputs
> -     (list pkg-config qttools-5))
> +     (list pkg-config qttools))
>      (inputs
> -     (list qtbase-5
> -           qtsvg-5
> -           qtdeclarative-5
> -           qtwebsockets-5
> +     (list qtbase
> +           qtsvg
> +           qtscxml
> +           qtdeclarative
> +           qtshadertools
> +           qtwebsockets
>             qtgraphicaleffects
> -           qtquickcontrols2-5
>             pcsc-lite
>             openssl))
>      (arguments
> -     `(#:modules ((guix build cmake-build-system)
> -                  (guix build qt-utils)
> -                  (guix build utils))
> -       #:imported-modules (,@%cmake-build-system-modules
> -                           (guix build qt-utils))
> +     `(#:qtbase ,qtbase
>         #:phases
>         (modify-phases %standard-phases
> -         (add-after 'install 'wrap-qt
> -           (lambda* (#:key inputs outputs #:allow-other-keys)
> -             (let ((out (assoc-ref outputs "out")))
> -               (wrap-qt-program "AusweisApp2" #:output out #:inputs inputs)))))))
> -    (home-page "https://github.com/Governikus/AusweisApp2")
> +         (replace 'check
> +           (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
> +             (when tests? (invoke "ctest" "--output-on-failure" "-j"
> +                                  (if parallel-tests?
> +                                      (number->string (parallel-job-count))
> +                                      "1"))))))))
> +    (home-page "https://github.com/Governikus/AusweisApp")
>      (synopsis
>       "Authentication program for German ID cards and residence permits")
>      (description

The rest LGTM, but it'd be best to use define-precated/public for
current users ausweisapp2; I think something like:

--8<---------------cut here---------------start------------->8---
(define-deprecated/public "ausweisapp2" ausweisapp)
--8<---------------cut here---------------end--------------->8---

Could you please send a v3 with the above changes?
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index a1fc058db8..3e46e318c3 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -950,43 +950,42 @@  (define-public nitrocli
 devices.")
     (license license:gpl3+)))
 
-(define-public ausweisapp2
+(define-public ausweisapp
   (package
-    (name "ausweisapp2")
-    (version "1.22.2")
+    (name "ausweisapp")
+    (version "2.1.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
-                                  "/download/" version "/AusweisApp2-" version ".tar.gz"))
+              (uri (string-append "https://github.com/Governikus/AusweisApp/releases"
+                                  "/download/" version "/AusweisApp-" version ".tar.gz"))
               (sha256
                (base32
-                "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+                "1jzxfybjrc3byw42bqjvn1nsn7vbgcl8y94sywjy6vaj3a58hy36"))))
 
-    (build-system cmake-build-system)
+    (build-system qt-build-system)
     (native-inputs
-     (list pkg-config qttools-5))
+     (list pkg-config qttools))
     (inputs
-     (list qtbase-5
-           qtsvg-5
-           qtdeclarative-5
-           qtwebsockets-5
+     (list qtbase
+           qtsvg
+           qtscxml
+           qtdeclarative
+           qtshadertools
+           qtwebsockets
            qtgraphicaleffects
-           qtquickcontrols2-5
            pcsc-lite
            openssl))
     (arguments
-     `(#:modules ((guix build cmake-build-system)
-                  (guix build qt-utils)
-                  (guix build utils))
-       #:imported-modules (,@%cmake-build-system-modules
-                           (guix build qt-utils))
+     `(#:qtbase ,qtbase
        #:phases
        (modify-phases %standard-phases
-         (add-after 'install 'wrap-qt
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (wrap-qt-program "AusweisApp2" #:output out #:inputs inputs)))))))
-    (home-page "https://github.com/Governikus/AusweisApp2")
+         (replace 'check
+           (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+             (when tests? (invoke "ctest" "--output-on-failure" "-j"
+                                  (if parallel-tests?
+                                      (number->string (parallel-job-count))
+                                      "1"))))))))
+    (home-page "https://github.com/Governikus/AusweisApp")
     (synopsis
      "Authentication program for German ID cards and residence permits")
     (description